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Release Notes Page 3
AdiIRC 1.9.6 - 28-03-2015
Added support for numeric rbg color value and html color value in the
config file
Added right click channel menuitem Nicklist -> Reset Default
Added allow alt + mouse click/move to move the main window when
there is no Titlebar
Added option to override windows theme and set
Menubar/Toolbar/Switchbar/Statusbar/MonitorPanels colors
Added Lock Bars menu item in panel tabs menu
Added ctrl + numpad0 keybind to reset font size in channel windows
Added ctrl + i keybind for Script Editor to invert the script list selection
Added ctrl + space keybind for opening contextmenu in
Editbox/Topicbox/Script editor
Added realtime spellcheck support using Nhunspell
Added option to enable/disable Nicklist prefix color
Added owner/protected font and colors for Nicklist/Treebar
Added draw focus rectangle on selected color in Options -> Color
Added separate font settings for Editbox/Inputbox/Messages
Added unlimited border size/line marker size
Added color and font settings for tray tips
Added right click menu "Save As" in Viewlog
Added right align nicks/resizeable nick colum with options in message
area
Added right click menu in Options -> Colors to allow copy/paste/reset
colors Support formats: rrr,ggg,bbb #rrggbb $rgb(rrrr,ggg,bbb)
Added option to show network name and/or nick name on Switchbar
status windows
Added option to show server info/ssl info in Statusbar
Added new MTS event ClientText
Added option to show/hide icon in Menubar
Added option Enable Menubar in Options -> Windows
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Added option tab for Switchbar in Options
Added option to set single or multiline Switchbar If Lock Bars is
enabled, Switchbar will split into multiple lines, else a overflow
button is shown. In single line, there is no multiline or overflow.
Added option and right click menu to set
Switchbar/Treebar/Menubar/Statusbar font
Added right click menu to set background image/layout for
Menubar/Toolbar/Switchbar/Statusbar
Added right click menu to set dock position for
Menubar/Toolbar/Switchbar
Added Nicklist buttons editor
Added new event Server Notices in Options -> Events
Added new sound event Buffer
Added new keybind shift + f5 to reload a script and send on LOAD
event in Script Editor
Added option to disable the sound when the window is focused
Added DPI support to most items
Added option to show Nicklist Tooltips with text parsed as scripts
Added option to show fake transparency to windows desktop
Added option to show fake transparency to the mdi window in Nicklist
Added triple click support for textboxes
Added right click menu Open Folder in plugin manager
Added ssl support for all internal links, update checks, search engines
etc
Added separate font and join/hide/quit etc events per channel
Added f5 keybind in Plugins Manager to reload plugins list
Added new API calls server.FindUser, server.FindChannel,
OnRawData, SendRawData
Added option to show/hide top panel in script editor
Added option to set pixel spacing between messages
Added option to set left message border
Added ctrl + i, ctrl + c keybinds in channel list
Added support for bold/italic/underline in all fonts
Added new keybinds ctrl + alt + left/right to cycle tabs including
minimized windows
Added option to set more lines in Editbox
Fixed removed shift + select keybind for selecting text + colors, use ctrl
+ select instead
Fixed delay track away status on connect to avoid connection lag
Fixed show a confirmation dialog when trying to paste more than five
lines into a single line Editbox
Fixed allow pasting multiple lines into single line Editbox
Fixed channel topic is not properly reset when rejoining a channel
Fixed Scrollbar settings should apply to Server/Channel monitor as
well
Fixed sometimes a nick appears twice in the nicklist with different nick
casing
Fixed allow using exe file icon as custom icons
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Fixed pageup/pagedown in a custom window without a textarea
causes a crash
Fixed [] brackets is not always parsed correctly in MTS themes
Fixed MTS Themes should not show empty part/quit messages etc
Fixed dcc transfers/chat request window should not block incoming
messages
Fixed custom font size is not restored in font dialog
Fixed allow selecting links when pressing shift without opening it when
single click links is enabled
Fixed changing window from the tray icon menu doesn't work
sometimes
Fixed Searching text in Searchbox can in some cases cause a crash
Fixed Rawlog should use the toolicon
Fixed text selection selects the wrong text when the buffer is full and a
new line is added
Fixed unescaped timestamps interferes with message linecolors
Fixed channel editor escape should close the color dialog
Fixed channel editor topic keybinds should be disabled in read only
mode
Fixed looking up hostname should change the Toolbar icon and
Titlebar text to connecting
Fixed with treebar "show left-to-right scrollbar" option enabled, the
name of the 1st network in the treebar will disappear when you
scroll too far
Fixed window location/size should be validated when
docking/undocking
Fixed re-docking a window to a minimized mainwindow, should restore
windowstate as the current windows
Fixed Trayicon tooltip text should use the /titlebar text and should
show connected servers and channels
Fixed /list modes are not parsed correctly on all networks
Fixed restore previous query/channel logs crashes on certain nicks
and channels
Fixed restore previous query/channel logs sometimes returns wrong
log files
Fixed NotifyUser(IUser,) api does not work properly
Fixed a fake channeluser should be created when none is found using
the api
Fixed OnUserMessage api target is null in query windows
Fixed Switchbar/Treebar colors and window blinking is sometimes not
reset when AdiIRC is focused
Fixed Menubar should re-hide when focus is lost, if Menubar is set to
hidden
Fixed escape should close search box in log viewer
Fixed plugins should be listed in the plugin manager even if it throws
an error on install
Fixed escape should close the search box if visible in custom windows
Fixed Searchbox should be disabled in picture windows
Fixed highlight tips shows the wrong title
Fixed disabled keybinds for font/colors tags in readonly Topicbox
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Fixed disabled drag/drop support on read only Topicbox
Fixed reduce amount of GDI objects to not crash when joining many
channels
Fixed scrolling is slow when using big background images
Fixed re-add image transparency to mdi image
Fixed font dialog dropdown should only trigger on typed characters
Fixed new script is not focused when script sidebar is hidden
Fixed Ctrl+Tab/Ctrl+Shift+Tab/Alt+left/right should ignore minimized
windows
Fixed clicking the Editbox/Topicbox border should give the window
focus
Fixed right clicking on a color in Options -> Color should focus the
color grid
Fixed scripts in Script Editor should only be saved when there is a
change
Fixed Tool popup window should adjust size automatically based on
content and screen size
Fixed Toolbar button background should apply to custom buttons and
Edit Toolbar buttons as well
Fixed serverlist should have scrollbars when needed
Fixed /logs should not show "Searching.." when there is no logs
Fixed Options split width is not restored properly
Fixed Editbox size should adjust automatically when changing number
of lines options
Fixed channel prefix should not be added if there is already a prefix in
irc:// links
Fixed Regain nick should not try to regain empty pref nicks
Fixed $channel doesn't work in Titlebar. Also, can't set caption on
query windows when undocked
Fixed highlights regex doesn't work
Fixed pressing escape on a desktop custom window should close it
Fixed changing background color in Editbox/Topicbox sometimes
leaves a unpainted border
Fixed event options for /names doesn't work
Fixed some variables are not unset on server disconnect
Fixed reopening a closed mdi docked panel causes a crash
Fixed ctrl + r in script editor should not toggle mute sounds
Fixed Mark As Read/Mark Server As Read menus should be disabled
if all windows are read
Fixed consolidate font chooser into one dialog, allow resetting fonts to
default value
Fixed delete file in Edit Aliases/Nicklist buttons should restore defaults
Fixed default background Image layout of
Menubar/Toolbar/Switchbar/Statusbar should be tiled
Fixed Channel modes incorrectly include channel prefix modes
Fixed Options -> Events -> Notice should be "In Active" by default
Fixed changing font in Treebar sometimes causes a graphic glitch
Fixed new version text in Update Form should automatically adjust to
fit
Fixed if marker line is visible when pressing ctrl + l, scrollbar should
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scroll to bottom
Fixed global hotkey is not working properly
Fixed show usermodes on Statusbar nick label
Fixed Highlight flash message and tip message times are not restored
properly in edit highlights dialog
Fixed Nick tips are showing the wrong nick name
Fixed mdi border is wrong when Showing/Removing Titlebar
Fixed server Notices should be shown in notice panel as well
Fixed MTS themes channel topics is displayed in the status window
Fixed windows settings is not saved properly when using /part
Fixed show a warning the first time sound mute is enabled/disabled
through ctrl + r
Fixed single click links doesn't work in Topicbox
Fixed whitespace before a link should not be clickable
Fixed connect button should open a empty server window if no there is
no open servers windows
Fixed server Disconnect/Connect menus should be enabled/disabled
depending on current server connected status
Fixed whois "has been idle" displays incorrect idletime if idletime is
less than 1 second
Fixed Topicbox colors should invert the same way messages does
Fixed pressing enter on a selected item in Options -> Colors should
open the choose color dialog
Fixed Day changed message can cause a crash with certain windows
open
Fixed Nicklist voice color doesn't work
Fixed Nicklist prefix colors/fonts should be visible on custom/random
nick colors as well
Fixed underline doesn't work properly with links in Topicbox
Fixed changing Nicklist size in options should override all manually
resized Nicklist's
Fixed italic fixedsys font is displayed incorrectly
Fixed hide now playing menu's unless a song is playing
Fixed default Treebar font is not applied on startup
Fixed clicking links doesn't work if Nicklist is hidden
Fixed toggling Nicklist autohide, should hide the Nicklist at once
Fixed hidden Nicklist can sometimes cause a crash
Fixed alt + f4 should close current active form, not mainform
Fixed Statusbar items are not restored correctly if options is saved with
Statusbar off
Fixed scrolling position is reset in Colors option window when clicking,
if scrolled down (on first click and when leaving color pick dialog)
Fixed panel form windows should save/restore docked
status/size/position
Fixed message colors are not updated immediately
Fixed /names target window and color is wrong
Fixed typing text in multiple languages in Editbox doesn't work properly
Fixed quick connect servers are filled incorrectly from the serverlist
Fixed background images -> Stretch should keep aspect ratio
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Fixed time variables %ff, %T, %TT is displayed incorrectly
Fixed typing nick search in Nicklist with no scrollbar causes some
nicks to be hidden
Fixed toggle Treebar folders on/off removes custom/fav icons
Fixed [] brackets from whois and channel info messages should be
removed
Fixed toggle nicklist in Treebar can sometimes cause a crash
Fixed "Allow only one copy" option can cause a ghost window to
appear
Fixed replacing text in Script Editor selects the wrong text
Fixed color popup dialog should be disabled in read only textboxes
Fixed channel background image should be updated immediately
Fixed docking of undocked monitor panel should be disabled if "Lock
Bars" is enabled
Fixed toolbar cpu/mem monitor should be transparent to the
background image
Fixed previous Treebar Folders expands when changing folder
Fixed numpad numbers should not close color form in Channel Editor
Fixed toggling Treebar folders on/off resets the new message color
Fixed undocked windows are not restoring window state correctly
Fixed right click channel -> Background -> Select uses wrong image
layout
Fixed right click channel -> Background -> Set as Default causes a
crash
Fixed channel password is not restored properly when using bnc's
Fixed default query invite to channel menu doesn't work
Fixed installing a update on startup sometimes causes a crash
Fixed overflowing buttons when moving/resizing Switchbar doesn't
always work correctly
Fixed always on top status should be saved across sessions
Fixed color dialog is not returning focus to Editbox when mainform is
"on top"
Removed boldify from topic to avoid font glitches
Removed /kill from default nicklist menu
Rename Inputbox to Editbox everywhere

Scripting:
Added ONKEYDOWN and ONKEYUP event for channels and queries
and allow using halt to override built in keybinds, use with
caution
Added new identifiers $keylocked, $font, $screenshot, $muted,
$lineheight, $starting, $exiting, $envvar, $tips
Added new commands /nickcolumn, /mute
Added new parameter -a for closing windows on all connections on
/close
Added new parameter -f -b for /nicklist
Added new parameter -i for /paths
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Added new parameter -u for /echo /echox
Added new parameter -t for /options
Added new parameter -r for /lock
Added new parameter -i for /edit
Added new parameter -qN for /window
Added new parameter -p for /close
Added new parameter -p for /clearall
Added new parameter -o for /clear
Added new parameter %var for /fakeraw
Added new operators isurl !isurl
Added new property .realname for $ial()
Added new property .wid for $dockpanels
Added new property .fontunderline for $window
Added missing parameters @menu -o for /toolbar
Added missing commands /copy, /flushini, /mdi
Added missing properties .bw .bh .idle for $window()
Added missing properties .selstart .selend .visible .enabled .isid .next
.prev for $did
Added missing properties .sq .rq for $sock
Added missing properties .wid .cid .hwnd .idle for $chan
Added missing identifier $keychar, $bname, $debug, $comchar
Added missing parameter -1 -2 -3 for $window
Added missing parameter -z for /server
Added missing parameters -n -p for $readini
Added missing parameter -e for /background
Added missing parameters M &binvar for $fread
Added dmissing parameters -f -v for /editbox
Added all missing parameters for /debug
Added missing dialog event "active"
Added missing event on MP3END
Fixed /echo N+ should be ignored
Fixed $var(*) does not work, $var().local/$var().secs returns wrong
value
Fixed don't allow //<space> //$ //%|evaluations in Editbox
Fixed /server -j #channel password does not wor
Fixed $regex $regsub $regsubex \xN doesn't work
Fixed $rgb with negative decimals returns wrong values
Fixed $uptime should return uptime in seconds since server was
connected
Fixed /alias should use default aliases when alias file is missing
Fixed $style doesn't work in $submenu
Fixed /did -g N does not work
Fixed allow multiline comments in menus
Fixed /drawpic filename is not validated correctly
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Fixed /clearall should clear dock panels as well
Fixed /drawtext with negative x y values doesn't work
Fixed Uclick event should only trigger on left mouse button
Fixed /echo -l should use the first word as highlight nic
Fixed $com().result $comcall().result sometimes returns wrong value
Fixed $com $comcall method DISPATCH_PROPERTYPUT does not
work
Fixed /alias deleting alias doesn't work
Fixed /encoding is not validated properly
Fixed MTS theme cache should use spaces for indentation
Fixed /window should focus editbox on desktop windows
Fixed /did -o replacing the first line does not work
Fixed halting some identifiers using $$ doesn't work
Fixed /dialog dclick event is not working for links
Fixed $hget() items can be a number
Fixed $bvar should not trim newlines
Fixed empty $exist() should return $false
Fixed $rgb(name) returns wrong value
Fixed /filter with only one target switch is not working correctly
Fixed $dde(,channels) should return channels from all networks, active
channel should be marked with a *
Fixed $regex/$regsub/$regsubex is sometimes slow
Fixed $calc add floor divide operator //
Fixed when restoring from minimzed state, windows are sometimes
moved down and/or resized. Happens mostly whith Aero Shake.
Fixed /sline should scroll the selected item into view
Fixed dclick $1- in listbox should return the line number
Fixed allow wildcards in @mouse events
Fixed WM_MCOMMAND and WM_MEVALUATE is not working
properly
Fixed $disk(unknown drive) should return $false
Fixed /dline allow N- lines
Fixed /savebuf is not saving the correct items
Fixed /splay add missing queue system
Fixed /splay play pos doesn't work
Fixed /say should be validated
Fixed /window -c should not show a warning if window doesn't exist
Fixed $chan(invalidchannel) should return same value as $chan(0)
Fixed /server port should be validated for valid range
Fixed $mp3() sometimes returns wrong values
Fixed $chr(160) should not be trimmed from scripts
Fixed on CLOSE event should trigger when channel windows are
closed as well
Fixed $mouse.key sometimes returns wrong value
Fixed /echo -l can cause a crash on custom windows
Fixed some identifiers querying Nicklist can cause a crash if Nicklist is
modified while querying
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Fixed /echo -n should not flash the Switchbar/Treebar icon
Fixed $regex $regsub $regsubex \cc \cb \co custom markers
Fixed /close -@ wildcard is not working
Fixed $window() add @wildcard support
Fixed $highlight().color $highlight().sound returns wrong value
Fixed $highlight() should strip colors/font tags before comparing
Fixed $cid and $wid and related identifiers/properties should be a
incremental number
Fixed /viewlog scroll position are sometimes reset when minimizing the
log window
Fixed $highlight(N) should ignore decimal numbers
Fixed allow @<$wid> in window related commands/identifiers
Fixed $window().dx $window().dy sometimes returns wrong values
Fixed /sockwrite should be executed after the script ends, and only
one on SOCKWRITE event should be triggered
Fixed $newnick returns wrong value
Fixed /showmirc /showadiirc -s should restore window from tray
Fixed /tip -c 0 does not work
Fixed $tip(0) returns wrong value
Fixed $fopen $fread $fgetc if name is a number, index in name list
should be used
Fixed dialog text items are sometimes created as multiline when they
shouldn't
Fixed alias keybindings is not working in undocked channel windows
Fixed on APPACTIVE is not always triggered correctly
Fixed $submenu items are not always validated correctly
Fixed /window -a should show the window if it's hidden and focus the
main window
Fixed menus are not working in picture windows
Fixed $feof returns wrong value
Fixed /notify -r should remove the nick from the Notify monitor panel
Fixed /dde $dde should be unicode
Fixed /window -h /window -w should not hide a Status Window from
Treebar
Fixed $findfile $finddir " should be removed from path
Fixed /lock doesn't work when restored from tray icon
Fixed cancel /lock dialog, should not minimize main window
Fixed allow identifiers in default part message to be evaluated
Fixed /window +borders should prioritize the first chosen border
Fixed disabled dialog text items are painted with wrong color
Fixed $timer().reps returns wrong value
Fixed on OPTIONS event should be called every time the config file is
changed
Fixed $nick is $null on ACTIVE and on CLOSE event
Fixed $bindip().ip returns wrong value
Fixed $replace/$replacex should show a error when using uneven
amount of parameters
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Fixed /nick on disconnected servers does not update the nick in the
statusbar
Fixed preload $cpuload to avoid it hanging on first run
Fixed /background should save background images for
Menubar/Statusbar etc
Fixed on TEXT identifiers using $1- in the message parameter doesn't
work
Fixed on ACTIVE should trigger when main window gets focus as well
Fixed /timer is not always associated with the correct server
Fixed $servertarget $lactivecid $status returns wrong value in some
cases
Fixed $strip is not stripping reverse character
Fixed $server and $nick is empty in on DISCONNECT event
Fixed /titlebar @window should include the window name
Fixed /titlebar shouldn't allow empty titles
Fixed identifier warning is sometimes shown incorrectly
Fixed invalid spaced brackets sometimes evaluates regardless
Fixed dialog id range does not work with dialog events
Fixed /did -o does not work for text labels
Fixed $replacex returns wrong value with multiple inputs
Fixed $color $colour /color /echo -c does not always find the correct
color
Fixed $snick sometimes returns wrong value if no nicks is selected in
the Nicklist
Fixed $myident/$myhost doesn't work in window titles
Fixed /titlebar should save/restore the title to the config file
Fixed /editbox [window] is not working properly
Fixed $ial().user should return ident
Fixed /background does not update custom background image menus
Fixed /.setconfig /.setoption should quiet the output
Fixed /query should not open a new window when multiple nicks is
defined
Fixed /close should only close windows on current connection
Fixed /slap allow multiple nicks
Fixed $read(,n) should return a random line
Fixed /window -o -u is not working properly
Fixed /window -k0 does not remove the @ from the titlebar on new
windows
Fixed /window -kXX is not validated correctly
Fixed $keyval returns wrong value
Fixed allow merging menu item if previous and current menu name is
the same
Fixed sub menu items in empty menu items are displayed incorrectly
Fixed $submenu sometimes causes a endless loop
Fixed some identifiers returns incorrect values in menus
Fixed menu's does not work when /remote is off
Fixed clearing a picture window linked to a toolbar button causes a
crash
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AdiIRC 1.9.5 - 05-09-2014
Fixed remove /kill from default nicklist menu
Fixed installing a update on startup sometimes causes a crash
Fixed version is incorrectly labelled as 1.9.5 beta
Fixed 64 bit stable version is checking for 32 bit update
Fixed /list does not work on some networks
Fixed /window -o -u is not working properly
Fixed /.remove should not print errors
Fixed $color(N) $colour(N) returns wrong value
Fixed /dialog allow - in front of options
Fixed /search /findtext should search in active window
Fixed picture window mouse events doesn't work
Fixed /drawtext is not always validated correctly
Fixed Treebar should be visible by default
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AdiIRC 1.9.4 - 01-09-2014
Added set background menu item for custom windows, if picture
window, allow saving the background as a file
Added option to autohide nicklist
Added option to set window order
Added option to show folders and folder count in Treebar
Added option to set inputbox/editbox single/double or automatic lines
Added menuitems to connect and connect in a new window in Serverlist
Added extended menu for rightclick Titlebar menu on undocked
windows
Added option to keep channels open when parting
Added filtering of html files in Help menu
Added theme manager right click menu Reload
Added md5/sha1 and pgp hashes for all exe files
Added f3 keybind for searchbox
Added open folder menu item in /logs
Added option in Script Editor to hide the script list and add keybind ctrl
+ r to toggle on/off
Added External Editor option in Script Editor and rightclick menu for
opening scripts/logs
Added regex support for filenames in /logs
Added searchbox and Ctrl + F keybind and rightclick menu for
channel/server monitor
Added shift + pagedown/pageup/home/end keybind in Nicklist
Added a minimum size for Switchbar and enabled overflow for
Menubar/Toolbar/Switchbar
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Added ctrl + i keybind in Logs manager and nicklist to invert selection
Added support for channel nick mode 'y'
Added DDE server support and options
Added shift + tab hotkey in Treebar to give focus to inputbox
Added option to animate trayicon on private messages
Added color names to numbered colors in Options -> Colors
Added $me variable for Options -> Nick Colors
Added right click Switchbar/Treebar menu to enable/disable monitoring
of a window
Added 1 pixel left border if Menubar/Toolbar/Switchbar is docked
vertically or Lock Bars is enabled
Added option to use small line marker
Added option to show/hide messages and Nicklist scrollbar
Added option to show/hide Titlebar
Added separate default icon for custom windows
Fixed MDI windows are some times "stuck"
Fixed default highlight options is missing if no config file is present
Fixed windows menu is slow with 80+ windows
Fixed context menus crashes with windows blinds
Fixed clicking menu separators should not close the menu
Fixed brackets is not parsed correctly in mts themes
Fixed tab character is not visible in menues
Fixed links are sometimes not clickable
Fixed ChannelMonitor/ServerMonitor colors is not updated
immediately when changing colors
Fixed double clicking on channel names in dockpanels doesn't work
Fixed Reset button in Edit Menus/Aliases should be before Close
button
Fixed connecting to a new server in a current server window, should
close all query and channels windows
Fixed Switchbar button tooltip text should be the associated window
text
Fixed Edit Aliases line numbers are 1 line off
Fixed alt tabbing to AdiIRC, focus should restore to script editor if it
previously had focus
Fixed custom nickcolor should work for your nick as well
Fixed allow drag/drop multiple scripts in Script Editor
Fixed allow duplicate menu items
Fixed menus with no sub menus and no script should be disabled
Fixed show fullscreen warning only once per session
Fixed there should be a menu separator between script menus and
remote menus
Fixed Theme manager -> open theme should filter by mts not mrc
Fixed last line of Rawlog -> Save/Buffer -> Save is missing
Fixed last character cannot be searched in Script Editor
Fixed disabled menu items should have an arrow
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Fixed menu check arrow is not centered correctly
Fixed Statusbar nick is missing prefix when joining a empty channel
Fixed default main window size should be a percentage of the screen
and centered
Fixed Treebar should be visible by default
Fixed Theme manager should open in the center of the mainform by
default
Fixed confirm closing server and channel windows should not ask on
other window types
Fixed timestamp in logs should be enabled by default
Fixed options -> Treebar, nicklist options should always be available
Fixed recent Files menu in Script Editor should be disabled if there is
no history
Fixed strip colors should not be enabled by default in Options ->
Logging
Fixed Korean characters are not displayed correctly/Possibly other
Asian characters as well
Fixed Theme manager should check if new theme is valid before
deleting any old theme
Fixed channels excluded from logging is not saved correctly in Options
Fixed reset ignore options doesn't work
Fixed Nicklist prefix is wrong on some networks
Fixed left click and moving the mouse in nicklist, should select nicks
Fixed sift + click in Nicklist doesn't work
Fixed ctrl + a doesn't work in all textboxes
Fixed closing a undocked window should close it instead of redocking
it
Fixed undocking a panel should give it focus
Fixed allow resizing Logs, save and restore size/location and allow it to
be docked/undocked
Fixed ctrl + k color dialog should be closed when changing window
Fixed clicking populate, then closing Channel List can cause the list to
be outputted to the status window
Fixed clicking Save All in Script Editor should ask for filename for new
scripts
Fixed if inputbox is multiline, ctrl + home/end should go to the start/end
of inputbox
Fixed allow moving text by drag drop in Script Editor, Inputbox and
Topicbox
Fixed tabbing between controls in Script Editor is not working properly
Fixed don't allow filename with only whitespaces in Script Editor
Fixed enter key in /logs should open viewlog
Fixed saving large scripts in Script Editor is slow
Fixed /logs -> Viewlog search match should be selected
Fixed double clicking channel name in a inactive channel window
doesn't rejoin the channel
Fixed ctrl + L is not always scrolling unread line marker into view
correctly
Fixed main window windowstate is not always restored correctly
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Fixed inputbox and topicbox should have a maxheight
Fixed list channels dialog menu uses the wrong style
Fixed spamming escape key in topicbox causes a crash
Fixed search should be reset in highlight panel before doing a new
search
Fixed when resuming after hibernate, only previously connected
servers should be reconnected
Fixed a potential crash on exit
Fixed tray icon is not always disposed correctly on exit
Fixed tray icon flash and tips don`t work with send to tray on minimize
Fixed inputbox text is not selectable unless the window has focus
Fixed cycling between inputbox/nicklist/topicbox with shift + tab is not
working correctly
Fixed border size changes is not updated immediately
Fixed page up/down in textview is one line off
Fixed treebar server font weight should not be bold by default
Fixed remove bold from switchbar items
Fixed reset Treebar options is resetting to the wrong font
Fixed line marker size changes is not updated immediately
Fixed flash option in highlight items is ignored
Moved Identd options into Server tab
Removed Options -> Window default sizes and use a percentage of the
mdi clientarea instead

Scripting:
Added missing parameters -gN -jN -kN -r -u -zN -v -r -i -l -S -s -H -x for
/window
Added missing parameters -a -h -l -n -s for/aline
Added missing parameters -h -l for /dline
Added missing parameters -a -h -s -l for /rline
Added missing parameters -a -s -r -l -e -c -m -n -t<topic> for /loadbuff
Added missing parameter -l -c for /clear
Added missing parameter -b for /drawtext
Added missing parameter 1 for $crc
Added missing commands
/filter,/savebuf,/autojoin,/color,/colour,/comclose,/comlist,/comop
en,/comreg,/showmirc,/showadiirc,/rline,/ddeserver,/dde
Added missing identifier
$filtered,$ebeeps,$alias,$bnick,$click,$cnick,$ctimer,$compact,$
dbuw,$dbuh,$leftwin,$leftwinwid,$leftwincid,$compress,$decom
press,$emailaddr,$findfilen,$finddirn,$fullname,$hash,$inroundr
ect,$lactivecid,$modefirst,$modelast,$onpoly,$stripped,$com,$c
omcall,$comval,$comerr,$dde,$isdde,$ddename
Added new command /highlight [on|off] and rightclick switchbar/treebar
menu -> Highlight to enable/disable highlights for that window
Added new command /fullscreen [on | off}
Added new command /lock <password> and ctrl + minimize keybind for
locking down the mainwindow
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Added new command /quickconnect toopen quick connect dialog
Added new identifiers $dockpanels,$sha2
Fixed /run is not always validated correctly
Fixed $gfx should be trimmed
Fixed on events matchtext/target is not always evaluated correctly
Fixed /run incorrectly reports an error on success
Fixed /gcmem should output to current window
Fixed $1 returns wrong value in some menus
Fixed /sysinfo default syntax $screen, should be $screen $+ ,
Fixed /google /pgoogle $decode(,h) decoding sometimes returns
wrong value
Fixed /query /queryfn <nick> should not send a query message
Fixed /window -wN is not hiding/showing window in Treebar/Switchbar
properly
Fixed $submenu punctuation marks should be ignored
Fixed /dialog -md with no location set, should open center screen
Fixed $encode $decode should use utf8 instead of ascii
Fixed /options /config [search] should select first matched node
Fixed /window default location should be center parent and size should
be a percentage of the parent client area
Fixed /dialog multiline text is not drawn and aligned correctly
Fixed /dock changing from one side to another doesn't work
Fixed /dock is not properly unregistered on exit
Fixed /dialog icon causes a crash if icon file is not found
Fixed single line /* comment */ is not parsed correctly in scripts
Fixed $lactive $lactivecid $lactivewid sometimes report wrong value
Fixed /dialog tables with invalid characters in numeric values is not
parsed correctly
Fixed using /.command recursively can sometimes cause a crash
inside scripts
Fixed /background is not always validated correctly
Fixed /if /while < > <= >= operators are returning wrong value when
comparing strings to numbers
Fixed /if /while > < >= <= !> !< !>= !<= operators returns wrong value if
one parameter is $null
Fixed $addtok is not always adding the token correctly
Fixed $qt should not add double quotes
Fixed on OP on DEOP on HOP on DEHOP on VOICE on DEVOICE
on BAN on UNBAN is missing $1Fixed /window -e should not add the first separator, if previous line is a
separator
Fixed wildcards in on event targets doesn't work
Fixed allow isignore/!isignore to be matched against switches
Fixed menuitems with brackets and no semicolon separator are not
parsed correctly
Fixed /loadbuf is not working correctly with some invalid parameters
Fixed $sline doesn't work with listbox in custom windows
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Fixed menu event dclick and lbclick doesn't work with listbox in custom
windows
Fixed $finddir and $findfile is not working correctly with some
parameters
Fixed /dialog -c before dialog is shown, causes a crash
Fixed /drawtext is not validated correctly
Fixed Empty menuitems should be removed instead of being invisible
in custom menus
Fixed $chan(#).mode is not sorted
Fixed /write should show an error if write failed
Fixed up/Down history is not working correctly in inputbox on custom
windows
Fixed key events from inputbox in custom windows are executed twice
Fixed $window().tbtext $window().tbstate returns wrong values
Fixed /window +l/+L is missing close button
Fixed /window -e0/-e1 is not working properly
Fixed /window -e should be allowed with any combination of -p -l
Fixed $submenu is not evaluating identifiers correctly
Renamed $docked to $dock and return Left/Right/Top/Bottom/None
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AdiIRC 1.9.3 - 13-07-2014
Added "Close" menu item in log viewer
Added ability to drag text into script editor/inputbox/topicbox
Added ability to filter by topic and min/max users in channel list
Added ability to filter/search options
Added background image options for statusbar
Added button to save channel list in Channel List dialog
Added channel list menu item in Tools menu
Added ctrl + tab nick completion in Options -> Nick colors and dialog
"edit"
Added Delete keybind in Logs manager
Added Events -> Motd to show/hide server motd on connect
Added keybinds for inserting color/font tags into tabcomplete options
Added keybind ctrl + a for Ignore List/Nick Colors
Added MusicBee now playing support
Added new highlight system with more options
Added new stacking balloon/tips system
Added option to enable/disable ctcp/event/raw in script editor
Added option to enable/disable flash icon in treebar/swittchbar
Added option to set/hide borderstyle on main window
Added option to show left to right scrollbar in treebar
Added option to show/hide day changed message
Added recent files menu in Script Editor
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Added right click menus in channel list
Added save channel list windows size/position
Added save cursor position in script editor
Added SMPlayer now playing support
Added sort button in ignorelist
Added support for %<tab> in input box
Added View -> Dock left/right/bottom/top menus
Added network/nick/channel information to Window -> Windows
Fixed #<tab> is not working properly
Fixed /betaup should enable check for new beta option
Fixed /google sometimes returns the wrong link
Fixed /list dialog should be cleared before a new list is retrieved
Fixed <colorchar><color><comma> is not parsed correctly
Fixed All windows should follow "Always on Top" from parent form
Fixed Allow column resize in /list
Fixed Allow smaller fonts than 8 in textview
Fixed Alt + left/right/up/down sometimes triggers a unicode character
in inputbox
Fixed Alt + Tab to AdiIRC causes main window to be moved last of the
tab order
Fixed Alt+Enter is moving one character off in input box
Fixed Alt+F4 does not exit
Fixed Away color is not updated in statusbar on /away /back
Fixed Changing channel password after making one in channel editor
doesn't work
Fixed Changing switchbar from horizontal to vertical makes the text
align wrong
Fixed Channel created/Topic set at should display as local time
Fixed Channel list should separate modes from topic and allow sorting
by modes
Fixed Channel list sort order saved in translated format causes a crash
Fixed Channel names can have : in them
Fixed Channel password/limit should be read only in channel editor for
normal users
Fixed Check for update doesn't work on mono if libgluezilla is not
installed
Fixed Clicking a icon in toolbar should revert focus to inputbox
Fixed Clicking Join in channel list shouldn't close it
Fixed Closing channel list search, should mute the output until finished
Fixed Color selector should close when pressing escape in script
editor, even if searchform is visible
Fixed Color should not flash in treebar/switchbar
Fixed Commands menu should give focus to inputbox after click
Fixed Copy text from inputbox should be in plain text
Fixed Copy text in topic box should give focus to input box if "focus
input box" option is enabled
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Fixed Corrupt positions.ini can silently close adiirc on startup
Fixed Ctrl + g doesn't work properly on undocked scripts editor
Fixed Ctrl + k in channel editor topic should show color dialog
Fixed Date/Time variable %fff sometimes is missing trailing zero
Fixed Dcc Get filestream is not always closed correctly
Fixed DCC Send/Recive/Resume/Accept file names can be quoted
and include spaces
Fixed Default slaps.txt should have \r\n newlines not \r
Fixed Double clicking channel names with special characters doesn't
work
Fixed Double clicking columns shouldn't join channels in Channel List
Fixed Double rightclick in nicklist should not open a query
Fixed Edit Menus should show a star when edited
Fixed Empty buffers should be ignored when trying to save a buffer to
file
Fixed Entering up or down key in theme manager with no selected
theme causes a crash
Fixed File paths is not working properly on mono
Fixed Flashing Treebar icons is not displayed correctly with large fonts
Fixed Focus should be restored to inputbox when clicking statusbar
items
Fixed Force logging option doesn't work and may cause a crash in
Options Dialog
Fixed Help files should open on desktop
Fixed Home/End in nicklist should select first and last nick
Fixed Home/End/PageUp/PageDown not working correctly in Treebar
Fixed If a treebar network was saved collapsed, channels should be
rejoined minimized
Fixed Images on Switchbar/Treebar should fade in/out when
highlighting
Fixed Incoming DCC should show full hostmask of the user in dcc
dialog
Fixed Initial dcc host is missing in Transfer monitor
Fixed Lag count should be reset on server disconnect
Fixed Line number height is wrong when using font size 10 in script
editor/textview
Fixed Log manager should not do a new search after deleting files
Fixed Logform should trigger a new search log folder or log file pattern
is changed
Fixed Maximizing main window with multi line topicbox causes a
graphic glitch
Fixed Menubar/Switchbar/Toolbar/Statusbar clicks are not received if
main window is not focused
Fixed Modes should be combined when mass removing
bans/invites/excepts in channel editor
Fixed Mouse cursor is flickering when hovering topic box
Fixed Mouseover top of the screen should show menu bar in full
screen
Fixed Nick casing should be updated whenever changed
Fixed Nick in Statusbar is empty when opening a new server window
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Fixed Nick's,channels,links should be double clickable in topicbox, but
not in edit mode
Fixed Notices from users should be shown in active or status window
Fixed Now playing only retrives 100 characters from some media
players
Fixed Only rejoin one channel upon reconnect
Fixed Open Folder in file transfer window should open the default
folder if there is no transfers
Fixed Opening options sometimes causes a crash
Fixed Painting input box/topic box border sometimes flickers
Fixed Prefix and messages should be separated by newline if
mainform is docked left or right
Fixed Pressing Alt in full screen should toggle menubar
Fixed Pressing Enter to make a new line in bug report textbox doesn't
work
Fixed Pressing escape asks to save in script editor even if color popup
is visible
Fixed Pressing Win+D minimizes AdiIRC if it's docked
Fixed Previous saved windows should not load broken nicklist visibility
Fixed Quit program warning should show connected server count
Fixed Random user list color is using the wrong color
Fixed Rawlog should load some lines from debug.txt when shown
Fixed RealName should not be saved if empty in quick connect
Fixed Remove CONF_ prefix from all items in config.ini
Fixed Removed toolbar items are sometimes restored
Fixed Rename casing in script manager should be allowed
Fixed Replace button "Connect All" with "Connect in new window" in
serverlist
Fixed Reset all window sizes menu should reset open windows as well
Fixed Resize while docked doesn't work properly
Fixed Restart AdiIRC doesn't work on mono
Fixed Restore logs can cause a crash if log folders have invalid
permissions
Fixed Restore logs options should always be available
Fixed Right click crashes on some windows versions without visual
styles
Fixed Script Editor "*" should be in front of file name in case the
filename is too long
Fixed Script editor "*" should be shown in the titlebar
Fixed Script editor menu click should register even if script editor
doesn't have focus
Fixed Script editor should ask to save modified script(s) when
unloading script(s)
Fixed Script editor should not be visible in taskbar unless "show on
desktop" is enabled
Fixed Script Editor should use selected script's path when clicking
Load/Save As
Fixed Script paths is not saved relative from Options
Fixed Scripts should be saved with \r\n newlines instead of \r
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Fixed Selected text in topicbox should auto deselect on click
Fixed Selecting nicks in Treebar nicklist doesn't work
Fixed Server history is not saved correctly
Fixed Setting the max message buffer to 0 shouldn't clear current
buffer
Fixed Shift + end on empty input box causes a crash
Fixed Shift + end without selecting newline at the end removed since it
doesn't work properly
Fixed Shift + home should scroll to left in script editor
Fixed Some global keybinds are sent twice in custom windows
Fixed Some key bindings is not working on mono
Fixed Some keybinds doesn't work in channel editor topic if it's
readonly
Fixed Sometimes winamp media player plugin detection incorrectly
asks to install plugin
Fixed Statusbar bandwidth should be shown with MB suffix
Fixed Switchbar, Toolbar and Docking panels are inverted on mono
Fixed Switchbar/Treebar icons should flash regardless of selected
window if main window is not active
Fixed Sysinfo OS version reports wrong OS on windows 8.1
Fixed Tab cycling empty word doesn't work
Fixed Text in mono version is not spaced properly
Fixed Textview should respect Windows scrollbar width
Fixed Theme manager is not working properly on mono
Fixed Theme manager should use selected theme name as filename
when clicking "save As"
Fixed Toggle Treebar icons doesn't work without restart
Fixed Tool popup dialogs should be topmost to associated form
Fixed Treebar focus should reset when it looses focus
Fixed Treebar items should only be selectable if the label or image is
clicked
Fixed Treebar query/system/tool colors are not reset correctly
Fixed Typing in scripts editor/input box doesn't work properly on wine
Fixed Use Nickcolors is saved to wrong section in the config file
Fixed User count is not updated properly in the statusbar on channel
join
Fixed User list colors is not refreshed at once when saving options
Fixed Using undo after saving a file in script editor, should mark the file
as edited
Fixed Variables can sometimes be reset in Tools -> Edit Variables
Fixed Viewlog form should save/restore window position
Fixed Weird behavior when a query chat partner revises his nickname
Fixed When "Lock Bars" is enabled, the custom border color should be
used for panels
Fixed While docked AdiIRC should hide/show if a app goes fullscreen
Fixed Whois and doubleclick on channel with (co)-oper
Fixed Winamp now playing stops working after its paused or until next
song starts
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Fixed Window order in treebar is not always sorted correctly
Fixed Word wrapping sometimes causes a endless loop
Fixed Wrapped text buffer is not emptied when exceeding "Max Buffer"
Moved all items from away.ini to config.ini
Moved all items from ignore.ini to config.ini
Moved all items from positions.ini to config.ini
Moved Tools -> Ignore List, Tools -> Nick Colors into Options
Removed Treebar menus from Treebar window menus because menus
are too big
Renamed channelbar and everything related to switchbar
Renamed sidebar and everything related to treebar
Renamed userlist and everything related to nicklist

Scripting:
Added /background -yz switches for statusbar/menubar
Added alias /options for /config
Added alias /setconfig for /setoption
Added default alias /i for /invite
Added missing commands /treebar /cline /queryrn /unsetall /tips /partall
/remote /ctcps /events
Added missing event APPACTIVE
Added missing identifiers $snicks $remote $ssl $pi $fullscreen $iptype
$portable $dccport $url $lactive $lactivewid $lof $tip $tips
$evalnext $titlebar $atan2 $hypot $log10 $sinh $cosh $tanh
$servertarget $menubar $switchbar $toolbar $treebar $highlight
Added missing operators isinvite isexcept isignore
Added missing parameter "me" for events
Added missing parameter -h for /run
Added missing parameter -iN for /echo and /aline
Added missing parameters -ie for /server
Added missing parameters -min/-max/channel/search for /list
Added missing parameters -npt for $read()
Added missing parameters parameter -n for /exit
Added missing properties .type .mmt .ansyc .pause for $timer
Added missing property "hsbar" for /dialog list
Added missing property .dd for $color() $colour()
Added missing property .lb for $window()
Added missing property .sig for $file()
Added new command /dockpanels [on|off] to toggle dock panels
Added new command /echox which takes a %var instead of text and
allows consecutive spaces
Added new command /edit -almnqsv for opening edit scripts etc
Added new command /rawx which takes a %var instead of text and
allows consecutive spaces
Added new event OPTIONS which is triggered whenever config file is
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reloaded
Added new identifier $docked returns $true if AdiIRC is docked
Added new identifier $lag returning lag on current server
Added new identifier $quickconnect returns $true if AdiIRC was started
with QuickConnect enabled
Added new identifier $randomcolors returns if random nickcolors is
enabled for message, nicklist or both
Added new identifier $statusbar returns $true if statusbar is visible
Added new identifiers $bwrecb and $bwsentb for byte format
Added new identifiers $msgx $rawmsgx to retrieve consecutive spaced
versions of $1- $rawmsg
Added new on event CLIENTTEXT for overriding messages sent from
the client
Added new parameter -d [encoding] for /server
Added new parameter [search] for /options and /config to search/filter
options dialog
Added support for ignoring multiple nicks in /ignore separated by
comma
Added support for OfficeIrc user prefix
Fixed on CTCP *:<matchtext>:command with no target doesn't work
Fixed on event target is not always evaluated correctly
Fixed on HOTLINK should be triggered on mouse down not click
Fixed on MENU separators is not always trimmed correctly
Fixed on RAW Some events are not triggered for scripts
Fixed on RAW the first : should be stripped from 301, 275, 338
Fixed on SOCKOPEN should be called even if the socket cant connect
Fixed on START/LOAD/UNLOAD/APPACTIVE/SONG/EXIT/SIGNAL
should be associated with current server
Fixed on TABCOMP does not always return correct tab completed text
Fixed on TABCOMP/INPUT is not always triggered correctly
Fixed on ^NICK is not halting the text properly
Fixed /alias /alias should not override the alias command
Fixed /alias Allow aliases without leading '/'
Fixed /anick with no parameters causes a crash
Fixed /background "Status Window" doesn't work
Fixed /background default image layout should be center
Fixed /bcopy -c is not chopping correctly
Fixed /bcopy <M> If M is -1, all of the bytes from position S onwards
should be copied
Fixed /beep 0 should stop beeps
Fixed /beep <delay> should be max 1000 milliseconds
Fixed /bin2txt is missing one character
Fixed /bindip is not working correctly with network adapters
Fixed /bindip quotes should be ignored
Fixed /bread is reading 1 byte off
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Fixed /clear [window] is not working properly
Fixed /clearall /aclear should only clear windows on current connection
unless -a is specified
Fixed /close add missing parameter -l
Fixed /ctcp PING should use $ctime
Fixed /dialog "edit" "combo" add color/font tag hotkeys
Fixed /dialog "edit" "list" size is wrong
Fixed /dialog "edit" add missing parameters hsbar vsbar
Fixed /dialog "list" add missing parameter sort
Fixed /dialog -md should not center the window if position is -1 -1
Fixed /dialog -s is resizing to wrong size
Fixed /dialog Add exe/dll/index support for "icon"
Fixed /dialog icon files not working
Fixed /dialog radio button with "push" should be text align center
Fixed /dialog sometimes crashes with invalid parameters
Fixed /dialog using menus makes the dialog to tall
Fixed /did -a and -r doesn't work with check/radio buttons
Fixed /did -a text should be trimmed
Fixed /did -i does not work on some elements
Fixed /did add missing parameters -s -l
Fixed /dns -46 <host> is not working
Fixed /dns doesn't work with ipv6 addresses
Fixed /drawcopy add missing switch -r and validate parameters
Fixed /drawdot parameters are not validated
Fixed /drawpic doesn't work with transparent images
Fixed /drawpic parameters are not validated correctly
Fixed /echo -l first word in a line should not be tested for highlight
Fixed /echo -l first word in a line should not be tested for highlight
Fixed /echo 1 1 is not showing correctly
Fixed /echo if active window does not have a textview, text should go
to associated status window
Fixed /exit -r does not restart the client
Fixed /exit without -n should ask to close active servers
Fixed /google search result should be html decoded
Fixed /help if no chm file is found, open relevant wiki page and
parameter -l forces open wiki page
Fixed /if /while &gt;< =>= operators are not working correctly
Fixed /if /while (number isnum) is not working properly
Fixed /if /while expressions using the ! operator are not returning the
correct value
Fixed /if /while is not working properly if first token is a operator
Fixed /if /while remove unnecessary operator %
Fixed /if /while(1 == 01) leading zeros should be trimmed
Fixed /ignore -x is ignored if below other ignore rules
Fixed /linesep add missing parameter -s and #channel
Fixed /linesep should not add a linesep if last message is a linesep
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Fixed /load -rs should always trigger LOAD/START
Fixed /lusers - display errors
Fixed /names Multiple channel prefix is not saved correctly
Fixed /nick should be trimmed
Fixed /notify blank mask should not be added
Fixed /np doesn't work with $user
Fixed /rename should be able to move folders
Fixed /search /findtext add missing parameter -n
Fixed /server -n should not connect
Fixed /server allow <host> <+port/port> <password> parameters
Fixed /server in on START event is not working properly
Fixed /server with no parameters should connect/reconnect current
server
Fixed /set -sl doesn't show output
Fixed /setoption doesn't work properly
Fixed /setoption with no parameters should reload config.ini
Fixed /sidebar on/off doesn't work properly
Fixed /socklist -l is not working properly
Fixed /sockmark name can be a wildcard
Fixed /sockwrite &binvar doesn't work
Fixed /statusbar View -> Statusbar saves to the wrong location in
config.ini
Fixed /time - not display the : into the time
Fixed /timer -o is not associated with current server
Fixed /timer add missing parameters -i and -o
Fixed /timer is not always validated correctly
Fixed /timer should show interval in seconds or milliseconds
depending on timer type
Fixed /timer sometimes causes a crash when AdiIRC exits
Fixed /timer with no name should be named as <n> not timer<n>
Fixed /toolbar -l does not update alias
Fixed /toolbar -p does not adjust icon size
Fixed /toolbar add missing parameter -zN and ico/exe/dll support
Fixed /toolbar doesn't work with transparent images
Fixed /toolbar on/off/no parameters doesn't work properly
Fixed /unload with quoted path doesn't work
Fixed /unnotify doesn't work
Fixed /var -g incorrectly prints value assignment
Fixed /var add missing parameter -n
Fixed /var halting doesn't work
Fixed /who output should be shown in server window
Fixed /window "Status Window" doesn't work
Fixed /window +d | +b should have no control box
Fixed /window +L is missing close button
Fixed /window -a is not restoring properly
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Fixed /window -c in a on CLOSE event causes a crash
Fixed /window -C is not centering the window
Fixed /window Add missing parameter -a
Fixed /write -s -w -r is not searching properly
Fixed /write add $crlf if -n is not set
Fixed /write should write utf8 with no BOM
Fixed $().properties in brackets doesn't work
Fixed $* does not work inside brackets
Fixed $0 returns wrong value
Fixed $1 in Menubar menus should be $me
Fixed $asctime() year format should be yyyy
Fixed $bindip should return $null if parameter is invalid ip
Fixed $bindip(N) returns wrong output
Fixed $bytes is not precise enough
Fixed $bytes(0) should return 0
Fixed $calc((1+)+1) and $calc(2^ %) is not working properly
Fixed $calc() with no parameters should return an error
Fixed $cb does not work correctly with unicode text
Fixed $chan().mode is not sorted correctly
Fixed $chan().pnick should return all channel prefixes
Fixed $chantypes is in wrong order on some networks
Fixed $cpuload and Help -> System variables sometimes causes a
crash
Fixed $ctime is returning wrong result
Fixed $ctime() doesn't work with XXnd dates
Fixed $dialog() add missing owner parameter
Fixed $dialog().modal is returning wrong value
Fixed $did add missing property .csel
Fixed $did returns wrong value when clicking a tab page
Fixed $did().text returns wrong value for listbox
Fixed $duration does not return correct value with doubles
Fixed $duration(x:x:x:x) doesn't work
Fixed $editbox .selstart .selend returns wrong value
Fixed $encode $decode add parameter h for encoding decoding html
codes
Fixed $encrypt $decrypt does not always work correctly
Fixed $event should be empty outside events
Fixed $exists returns $false on mono regardless of path
Fixed $false should return the value $false
Fixed $file() should work with directorys
Fixed $fline does not always return correct value
Fixed $gfxram should be rounded
Fixed $inpaste does not always return the correct value
Fixed $input Change tab complete to ctrl + tab complete so change
focus with tab works
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Fixed $input control code keybinds should work
Fixed $invitemenu should use same sort order as switchbar/treebar
Fixed $isalias() add missing property .alias
Fixed $isalias() doesn't work with local aliases
Fixed $left $right should return $null if second parameter is not a
number
Fixed $lines() is returning wrong value in some cases
Fixed $log(0) $log10(0) should return $null
Fixed $longip() sometimes returns wrong value
Fixed $longip() with no ip defined should return nothing
Fixed $mid does not always return correct value with negative
numbers
Fixed $mid doesn't work with doubles
Fixed $mknickfn is not stripping the correct characters
Fixed $modespl is returning wrong value
Fixed $mouse.dx and $mouse.dy returns wrong coordinates
Fixed $nick should be $null outside server related events
Fixed $or should be uint and allow only one parameter
Fixed $pic().width $pic().height causes a crash with invalid pictures
Fixed $player should return chosen media player regardless of play
state
Fixed $pos returns wrong value
Fixed $pos(x,x,N) $poscs(x,x,N) does not return correct result
Fixed $rand should allow 64 bit random numbers
Fixed $read -r does not fill $regml
Fixed $read() can cause a crash
Fixed $regex $regsub $regsubex (*UTF8) should not be included in
the pattern
Fixed $regex $regsub $regsubex doesn't work properly with global
regular expressions
Fixed $regex $regsub $regsubex fails with underscore characters in \Q
\E
Fixed $regex $regsub $regsubex with escape codes can sometimes
cause as crash
Fixed $regsub $regsubex substitution codes should be replaced with
$+ code $+
Fixed $regsub $regsubex \1 \2 is not always replaced correctly
Fixed $round is not validated correctly
Fixed $scriptdir crashes from inputbox
Fixed $server should return $null if not connected
Fixed $sha1 should return lowercase result
Fixed $slapsmenu(0) should return number of slaps
Fixed $sock().ssl returns inverted value
Fixed $sock().wserrmsg should be called wsmsg
Fixed $sockbr returns wrong value
Fixed $str() crashes with too high value
Fixed $strip add missing parameters burcmoi
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Fixed $submenu doesn't always add separators correctly
Fixed $timer().secs is returning wrong value
Fixed $timer(name) should return position
Fixed $v1,$v2,$ifmatch and $ifmatch2 sometimes returns wrong value
Fixed $window(N) doesn't work
Fixed "Upgrade" old media player format from '$song' to ' $+ $song $+
'
Fixed $mouse.key returns wrong value in picture windows
Fixed Channel collection for IUser in API is empty
Fixed Double spaces in scripts are not always parsed into single space
Fixed Errors inside identifiers doesn't halt the script properly
Fixed IUser in API events is sometimes empty
Fixed menu sclick should trigger on mouse down instead of click
Fixed Parentheses is not always parsed correctly
Fixed Pressing escape in a custom window should minimize it
Fixed Script variables are sometimes reset on EXIT
Fixed Scripted menu's should only trim white spaces
Fixed Some variables is not correctly passed from alias to $identifier
and back
Removed unnecessary commands /loopfile /split
Removed unnecessary identifiers $myhost $myident $activeserver
$channel
Removed unnecessary operators hasvoice inchan isbetween

sort_asc.png
%(cpp cbg)« Previous%%(cpn cbg)1%%(cpn cbg)2%3%(cpn cbg)4%%(cpn cbg)5%%(cpn cbg)6%%(cpnext cbg)Next »%

06/20/2019

27/27

