Project

General

Profile

Bug #1296

DCC resume does not work

Added by Thomas Zick about 5 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Irc
Target version:
Start date:
05/18/2014
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

DCC resume does not work. File transfers always restart at 0% (regarding to the transfer window).
But ADIIRC does not remove the old file, it continues to write in it. The file gets bigger than the original and is corrupted.

History

#1

Updated by Per Amundsen about 5 years ago

  • Category set to Irc
  • Status changed from New to Assigned
  • Assignee set to Per Amundsen
  • Target version set to 1.9.3

Thanks for reporting, I'll do some tests and see what's up.

#2

Updated by Per Amundsen about 5 years ago

Oops I see you have reported this before in the forums, sorry about that I forgot.

#3

Updated by Per Amundsen about 5 years ago

Hi, I have done many dcc resume tests and asked some other users to test, and so far dcc resume seems to be working correctly.

Could you try explain the dcc transfer workflow that leads to this error?

And/Or is it possible for me to test dcc transfer at the same place you experience this?

#4

Updated by Thomas Zick about 5 years ago

That's strange. For me, dcc resume doesn't work at all, regardless of the file size, file type, irc channel, etc.

Resume is working fine with all other irc clients I've tried.
Sorry, forgot to mention this: These are XDCC transfers (not classic DCC transfers).

I'm using AdiIRC 1.9.3 beta

1. I start receiving a file using the xdcc send command.

2. The download is interrupted/I interrupt the download process manually.

3. I try to resume the transfer using the same command I used in step 1.

4. Download starts, AdiIRC continues to write the file, but regarding to the transfer window it restarts at 0%. When I let the download finish, the downloaded file is bigger than it should be and it is corrupted.

#5

Updated by Erland Nuyts over 4 years ago

I have the same problem, resume keeps old part and starts from the beginnen after the old part.

I really like AdiIRC and I want to keep using it but this is a vital part for me

Any new info (solutions) on why this happens?

I'm using version 1.9.5 x64 - win 7
I also only use xdcc and works with all other irc clients

Thanks for reading this :)

#6

Updated by Per Amundsen over 4 years ago

Can you point me to a specific place where I can test this and see if I can replicate?

If you are worried about secrecy you can either email me the network/bot/file or pm me (kr0n) on irc.nordicirc.com or chat.freenode.net

#7

Updated by Per Amundsen over 4 years ago

ups email is

#8

Updated by Per Amundsen almost 4 years ago

  • Status changed from Assigned to Resolved
  • Target version changed from 1.9.3 to 1.9.9

I think I finally found the cause of this issue, fix will be in next beta.

#9

Updated by Jack Sparrow over 3 years ago

Has this been implemented in v2.2? because i am also experiencing this bug with the lastest stable, with auto-accept off i get the resume/overwrite dialog, but with auto-accept on i am having the same issue as mentioned in the OP.

edit: nvm, just saw the beta where it was fixed is labeled 2.3, feel free to delete this.

#10

Updated by Per Amundsen over 2 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 1.9.9 to 2.7
  • Operative System changed from Windows 7 to All

Many resume bugs where fixed for bext beta, if there still are issues, please let me know, closing for now.

Also available in: Atom PDF