Project

General

Profile

Bug #130

Sudden loss of channel activity (unable to recieve messages)

Added by L CD over 9 years ago. Updated over 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
03/03/2009
Due date:
% Done:

0%

Estimated time:
Operative System:
Windows Vista
Regression:
No

Description

I've had this problem at least twice. On Windows XP and more recent, on Vista.

Sometimes the channel activity completely dies. No error logs or anything. I can still send messages (others can read them too), I can't however read their messages. It's a very strange problem indeed and the only solution I've found is reinstalling the program.

  • Can't see other peoples messages
  • This includes private chats
  • No MOTD (channel bar) is visible

However,

  • "Quit" messages are working (when user disconnects)
  • Connection to QNet is established
  • Channel user list is visible
  • Everything else generally works fine

=================================================
My system for bug tracking
(unfortunately it's all I can provide right now
if there are any error logs to look for please tell me)

Windows Vista (w. jan updates), (bug exists on XP as well)
ATI Radeon (Catalyst) 9.1
AdiIRC
Comodo Personal Firewall
Intel Matrix Storage (RAID5)
Realtek Audio Drivers

Hardware; C2D E6400, 2 GB RAM, GFX ATI 2900XT (if that matters)

History

#1

Updated by L CD over 9 years ago

========= UPDATE ===========

It's a bug!

CAUSE: Some parameters in user ignore list 'ignore.ini' blocks all incoming messages.

SOLUTION: Remove all entries from the list.

Developers: There's something wrong with the syntax in ignore.ini that for some reason blocks all incoming messages. I think "AdiIRC.exe" reads it wrong for some reason. Try it out youself (create a ignore.ini file with this [my] content)

1¦15/02/2009 00:04:51¦iNetHero
1¦17/02/2009 02:26:36¦XquteXL
1¦22/02/2009 03:44:45¦NiP|HeatoN
1¦23/02/2009 00:58:31¦Speakeasy
1¦23/02/2009 01:49:50¦IntrA
1¦23/02/2009 01:50:00¦ChungLi
1¦23/02/2009 01:51:00¦lizco
1¦03/03/2009 02:20:41¦|dev|Lego

What debug.txt says (actually special nothing at all):

04/03/2009 00:14:12 - Connnect called
04/03/2009 00:14:12 - Connnect called and working
04/03/2009 00:14:12 - ConnectLoop started
04/03/2009 00:14:12 - ConnectLoop onlookup called
04/03/2009 00:14:12 - ConnectLoop hostok
04/03/2009 00:14:12 - ConnectLoop onconnect called
04/03/2009 00:14:12 - ConnectLoop socket init
04/03/2009 00:14:12 - ConnectLoop socket startet
04/03/2009 00:14:12 - ConnectLoop isClosed = False
04/03/2009 00:14:12 - Start Readthread
04/03/2009 00:14:12 - Readthread startet
04/03/2009 00:14:12 - Start Writethread
04/03/2009 00:14:12 - Writethread startet
04/03/2009 00:14:12 - Start Pingthread
04/03/2009 00:14:12 - Pingthread started
04/03/2009 00:14:12 - Start Listenthread
04/03/2009 00:14:12 - Listenthread startet
04/03/2009 00:14:12 - OnConnected called
04/03/2009 00:14:12 - OnConnected running
04/03/2009 00:14:12 - OnConnected serber = ok
04/03/2009 00:14:12 - OnConnected serber = ok sent
04/03/2009 00:14:12 - YOU ARE 100% CONNECTED
04/03/2009 00:15:16 - All ok, closing

Hope this helps. This is all I can provide. Good luck fixing the bug!

Thanks for a great program!

/IM

#2

Updated by Per Amundsen over 9 years ago

You are totally right about that, its fixed, but the syntax in your ignore file is wrong, it should be:

Nick!**
Nick2!*

Nick3!
@*

etc and not just the nick.

Ps. Excellent debugging work and bug report!

#3

Updated by Per Amundsen over 9 years ago

  • Status changed from New to Assigned
#4

Updated by Per Amundsen over 9 years ago

  • Status changed from Assigned to Resolved
#5

Updated by Per Amundsen over 9 years ago

Posting because email notifications wasn't working before.

#6

Updated by Per Amundsen over 9 years ago

  • Target version changed from 1.8 to 1.8.3
#7

Updated by Per Amundsen over 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF