Project

General

Profile

Bug #1521

closed

Tray icon flash and tips don`t work with send to tray on minimize

Added by Dan Paduroiu almost 7 years ago. Updated almost 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
08/12/2014
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

As the subject states both tray icon flashing on PM and tips on PM don`t work when minimized to tray. They both work just fine when the program is closed to tray.


Files

highlights.png (33.9 KB) highlights.png Highlights Dan Paduroiu, 08/12/2014 09:11 AM
tips.png (35.8 KB) tips.png Tips Dan Paduroiu, 08/12/2014 09:11 AM
tray.png (20.6 KB) tray.png Tray Dan Paduroiu, 08/12/2014 09:11 AM
#1

Updated by Per Amundsen almost 7 years ago

Hi,

I just tested in 1.9.4 beta 2014/08/11 with various combinations of Tray settings and everything seems to work as expected.

Can you maybe post some screenshots of your Tips/Tray Icon/Highlights options ?

#2

Updated by Dan Paduroiu almost 7 years ago

I forgot to mention that i had this problem for a week, a week and a half, i cant remember exactly and i update to the latest beta daily. I use the 64 bit .net 4.0+ version on windows 8.1 64 bit.

I also did a clean install of version 1.9.4 beta 2014/08/11, but the problem was still there.

I`ve attached the screenshots.

#3

Updated by Per Amundsen almost 7 years ago

Thanks, I have tested with these options and still can't replicate.

Can you clarify somthing, you said it doesn't work when minimized to tray, but it works when closed to tray, what is the difference ?

#4

Updated by Dan Paduroiu almost 7 years ago

Yeah, closed to tray is when you press the close button (the X) and the app doesn`t close, it goes to tray as an icon. Minimize to tray is when you minimize the app (press the _ button), but the app doesn`t go to the taskbar as a minimized window, instead it goes to tray as an icon.

I did some more testing, after you close to tray, restore the app and minimize it back to tray the flashing begins to work.

Some stept to reproduce: a fresh started instance of the app, connected to undernet with the settings from the pictures, goes minimized to tray and in parallel i`ve started an instance of another irc clinet and started to PM myself. No flashing, no tips. If i restore the app, the PM`s are there.

I`ll try to do a screen recording later if you still can`t replicate.

#5

Updated by Per Amundsen almost 7 years ago

Thanks a video would be very helpful if possible.

Think you are onto something good here :)

#6

Updated by Per Amundsen almost 7 years ago

Btw if it contains any private channels/servers or something, you can email it to me on

#7

Updated by Dan Paduroiu almost 7 years ago

Now while trying to record i`ve noticed that i`m a moron. The bug appears when you minimize the window not by clicking the minimize button, but when minimizing it by clicking on it on taskbar. I have such a reflex to do this that i didnt event noticed that i write one think and do another.

Here is the recording.

https://dl.dropboxusercontent.com/u/187618/Screen%208-12-2014%20(11-13-20).avi

#8

Updated by Per Amundsen almost 7 years ago

Excellent, I can reproduce this and I think this bug is related to some other oddities as well.

I'll fix this for next beta, thanks!

#9

Updated by Dan Paduroiu almost 7 years ago

Perfect, thank you too. I`ll take down the video if you saw it.

#10

Updated by Per Amundsen almost 7 years ago

Yes I saw it.

#11

Updated by Per Amundsen almost 7 years ago

  • Category set to Interface
  • Status changed from New to Resolved
  • Assignee set to Per Amundsen
  • Target version set to 1.9.4
#12

Updated by Per Amundsen almost 7 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF