Project

General

Profile

Bug #159

$channel returns a malformed channel name

Added by Pau Ruiz Safont almost 10 years ago. Updated about 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
09/04/2009
Due date:
% Done:

0%

Estimated time:
Operative System:
Windows 7
Regression:

Description

When using the variable $channel in a custom command, AdiIRC returns "nel" to the channel name.

Example:
having this command:

/cop /cs op $channel $1

and using it in a channel named #anaitgames

the DAL.net server throws this error:

ChanServ< The channel #anaitgamesnel is not registered.

It happens also in other servers.

As a sidenote, after idling some time in a channel I can recieve messages from the channel, but I cannot sen any, as the program complains about not being in the channel. I'm forced to reconnect to the server to send a message. I suspect the "nel" may be the cause of this.

This happnes using AdiIRC 1.8.3 in Windows 7 RC, I don't remember this happenning in previous versions.

History

#1

Updated by Per Amundsen over 9 years ago

  • Status changed from New to Assigned
  • Assignee set to Per Amundsen
  • Target version set to 1.8.4

if you update to latest beta, the reconnect thing is fixed, ill have a look at channel variable.

#2

Updated by Pau Ruiz Safont over 9 years ago

Issue still happens with the newest beta.

Though the error when trying to send a message after rejoining has been fixed, thanks!

#3

Updated by Per Amundsen about 9 years ago

  • Status changed from Assigned to Resolved

Just noticed there is no alias named "$channel", only "$chan", i have made both now, good catch.

#4

Updated by Per Amundsen about 9 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF