Project

General

Profile

Bug #1769

closed

Channel titlebar caption

Added by Andreas vb over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
12/10/2014
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

$channel doesn't seem to work in titlebar.

Also, can't set caption on query windows (when external, not in MDI mode, it changes its channel's).

#1

Updated by Per Amundsen over 6 years ago

Hm, I can't replicate any issues with titles, are you using the latest beta?

Also can you post a screenshot of the problem along with your window title options?

#2

Updated by Andreas vb over 6 years ago

on *:ACTIVE:#:/titlebar $channel $network

Only $network is working, using that in the mean time.
Variables only seem to work in script, when typing it in the inputbox it just use it literally, not as a variable.

Options:

$version - $channel
$version - $network - $nick
$nick!$ident@$host - $version

Always latest beta. :)

#3

Updated by Per Amundsen over 6 years ago

Oh you are using /titlebar, in that case you need to use normal scripting identifiers like $chan :)

Also, can't set caption on query windows (when external, not in MDI mode, it changes its channel's).

Still not sure what this means ?

#4

Updated by Per Amundsen over 6 years ago

Nbm I see what you mean, for query's you need either to add a new active event e.g on *:ACTIVE:?:/titlebar $nick

However, $nick is not set for this event, I will fix that.

#5

Updated by Per Amundsen over 6 years ago

Try use $target instead of $nick

#6

Updated by Andreas vb over 6 years ago

Query works when it's MDI but not on desktop, it says:
Desktop: "AdiIRC - nickname ident - version..."
MDI: "nickname - [nickname ident - version...]

The channel works now at least, with: "on *:ACTIVE:?:/titlebar $target ][ AdiIRC"

#7

Updated by Per Amundsen over 6 years ago

I'm so confused, but the /titlebar command only changes the part before MDI, to change the other part, you use the Titlebar Options, they use different variables though.

#8

Updated by Per Amundsen over 6 years ago

Maybe this is what you want, on :ACTIVE::/titlebar $target $network

#9

Updated by Per Amundsen over 6 years ago

Forgot to format

on *:ACTIVE:*:/titlebar $target $network
#10

Updated by Andreas vb over 6 years ago

This is what I would like:

MDI: channel ][ AdiIRC - [version]
Desktop: nickname ][ AdiIRC - [version]

When using on *:ACTIVE:?:/titlebar $target ][ AdiIRC
And Priv Titles: $version

I get following as title on query windows:

Desktop: AdiIRC - version
MDI: nickname ][ AdiIRC - [version]

#11

Updated by Per Amundsen over 6 years ago

I see, very odd, this works for me with query's *:ACTIVE:?:/titlebar $target ][ AdiIRC

#12

Updated by Andreas vb over 6 years ago

On desktop windows?
Open a query, press Ctrl+D.
Mine only says what's in options, but with AdiIRC in front, doesn't use any script.

#13

Updated by Per Amundsen over 6 years ago

Oh now I see what you mean, unfortunately you can't change the Titlebar for "Desktop Windows" besides the Titlebar Options.

#14

Updated by Andreas vb over 6 years ago

Can't you change the code so it's before the program name?
It's hard to know which window is which when the taskbar only says: #channel ... AdiIRC -... AdiIRC -... AdiIRC -... =/

I made a script with AHK that removes the 8 first characters with title matching, not the cleanest way, but meh.

#15

Updated by Per Amundsen over 6 years ago

I'll see if I can make a hack for this.

#16

Updated by Per Amundsen over 6 years ago

  • Status changed from New to Resolved
  • Target version set to 1.9.6

"AdiIRC - " is removed in next beta :)

#17

Updated by Per Amundsen over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF