Project

General

Profile

Bug #1896

closed

Show last X messages in a query with same username as channel

Added by r w over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Low
Assignee:
Category:
Interface
Target version:
Start date:
01/26/2015
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

extremely low priority, I doubt many people would ever run into this;

With Logging enabled and the "Show last X messages in private windows" option enabled:
open a query with a user that has the same name as a channel with logs (ex. user "test" and channel "#test"). It loads the logs BOTH from the channel "#test" AND the previous query with "test".

expected result is to ignore the channel log and only show query log

AdiIRC v1.9.6 Beta Build 2014/12/30 64 Bit | Windows 8.1

#1

Updated by Per Amundsen over 6 years ago

  • Status changed from New to Assigned
  • Target version set to 1.9.6
  • Operative System set to All

That's a pretty bad bug, can you post a screenshot with your logging settings?

#2

Updated by r w over 6 years ago

The amount of lines it loads (in the query window) follow the channel setting as well. In the query, it would load 250 lines instead of just 50 as per my screenshot.

#3

Updated by r w over 6 years ago

lol actually just tested more and this only happens because of the format I use for FileName.. my bad.

with the default "$network - $channel" it doesn't happen (because the channel filename is different from the query filename)

#4

Updated by Per Amundsen over 6 years ago

  • Status changed from Assigned to Resolved

Both of this issues are fixed for next beta, good finds, thanks.

#5

Updated by Per Amundsen over 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF