Project

General

Profile

Actions

Bug #2207

closed

Auto-Update not working properly

Added by Leonel Faria over 7 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
09/28/2015
Due date:
% Done:

0%

Estimated time:
Operative System:
Windows 8.1
Regression:
No

Description

AdiIRC detects that is has a new version for update, it downloads the update but when I press install it just restarts AdiIRC but it still is on the previous version. If this is done only by auto detect it never installs the new version.

If I press Check Updates it detects a new version, I do all the same (download, install) restarts and now yes it changes to the new version.

Not a big issue for me, just thought that you would like to know about it.

Actions #1

Updated by Per Amundsen over 7 years ago

Please type and run this command in your AdiIRC and copy/paste the result here.

//echo -ag $version - $builddate - $bits - $dotnet
Actions #2

Updated by Leonel Faria over 7 years ago

Per Amundsen wrote:

Please type and run this command in your AdiIRC and copy/paste the result here.

Result: 1.9.7 - 2015/09/26 - 64 - v2.0.50727

But i've just updated, bucause I ran the Check for updates from the menu.

I was on the version of August since quite long...I wasnt bothered about it because it was running smoth...today intrigued by the "not updating" thing I tried to run it from the menu...and it updated properly...

I think I have another computer with old version at home (that also doesn't auto-update), I can give it a try and show you later.

Actions #3

Updated by Leonel Faria over 7 years ago

Leonel Faria wrote:

I think I have another computer with old version at home (that also doesn't auto-update), I can give it a try and show you later.

I thought I had it on the other computer, but its with the stable version, so can't reproduce...

Actions #4

Updated by Per Amundsen over 7 years ago

  • Category set to Interface
  • Status changed from New to Assigned
  • Assignee set to Per Amundsen

Thanks anyways.

I have not been able to reproduce either, it might have been a one off/random bug.

Let's see in a few beta versions if it happens again.

Actions #5

Updated by Leonel Faria over 7 years ago

Per Amundsen wrote:

Thanks anyways.

I have not been able to reproduce either, it might have been a one off/random bug.

Let's see in a few beta versions if it happens again.

Ok, new beta version and auto-update failed.

It detected sucessfully, I click download, then install AdiIrc restarts but it is still on the old version.

Running the command you asked me I get:
1.9.7 - 2015/09/26 - 64 - v2.0.50727

Actions #6

Updated by Per Amundsen over 5 years ago

I made several changes to the update program, but the update program is only used when running in non-portable mode, just wondering if you are running portable or installed into c:\program files ?

Actions #7

Updated by Leonel Faria over 5 years ago

Per Amundsen wrote:

I made several changes to the update program, but the update program is only used when running in non-portable mode, just wondering if you are running portable or installed into c:\program files ?

I have it instaled into c:\program files but it seems to be working properly...

Actions #8

Updated by Per Amundsen over 5 years ago

  • Status changed from Assigned to Closed

great!

Actions

Also available in: Atom PDF