Project

General

Profile

Bug #2348

closed

Logs windows Crash

Added by shinagora shinagora almost 6 years ago. Updated almost 6 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Interface
Target version:
Start date:
11/22/2015
Due date:
% Done:

0%

Estimated time:
Operative System:
Windows 10
Regression:
No

Description

Hello,

When i have actived the logs on message private (by nick) in options, the client (AdiIRC) crash now only when i open logs windows (/logs).

History :
Before i have checked only channel logs, and it was good (windows logs OK). And now i have checked on private message, and the script crash.

#1

Updated by Per Amundsen almost 6 years ago

Did you submit a crash report from the crash?

Also what version of AdiIRC are you using?

#2

Updated by shinagora shinagora almost 6 years ago

The logs error is empty. (surely because the client crash, dont close the window, its pending, i need close with ctrl+alt+del)

My version is the last : 1.9.9 64 bit

#3

Updated by Per Amundsen almost 6 years ago

Without a crash report it's not much I can do.

Would you be able to list all the filenames in your log folders, maybe one of them causes the crash.

If you are worried about privacy, you can email them to

#4

Updated by shinagora shinagora almost 6 years ago

I listed all files in directory log, the log for server and private message its OK, the files is created. But the windows log in the client dont work, crash again.
After i have delete all log, but dont work too.

I think the bug is in windows /logs. When i type /logs, the windows log open the icon in top of client and left (where they are channels list) but waiting and crash the script.

Sorry, i understand its difficult if you have no report from the crash :(

Thank you, your script is very good, and I continue to use same with this small problem :)

#5

Updated by Per Amundsen almost 6 years ago

Okay that does narrow it down.

Try open your config.ini .. (you can type /paths -o to open the config folder) and copy paste the lines under [LastLogs], if there is a username in it, you can blank that out, just need to see if there is anything wrong in the paths.

You could also try delete this section and see if that fixes the problem.

#6

Updated by shinagora shinagora almost 6 years ago

Thank you for the fast replies,
Then i checked the config.ini (lastlogs), i had many lines (60 000 lines)

Content :
n0=.\Logs.
n1=.\Logs

etc...

Maybe that causes the bug (overloaded).
I have delete all lines, reloaded the client and its work now =)
Thank you again for your support

#7

Updated by Per Amundsen almost 6 years ago

  • Category set to Interface
  • Status changed from New to Resolved
  • Assignee set to Per Amundsen
  • Target version set to 2.0

Ah yes this was fixed in #2313 this is very bad, will make a new release soon with fix, thanks.

#8

Updated by Per Amundsen almost 6 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF