Project

General

Profile

Bug #273

closed

Updater locked file

Added by Jeroen z0r almost 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Interface
Target version:
Start date:
02/07/2011
Due date:
% Done:

0%

Estimated time:
3.00 h
Operative System:
All
Regression:
No

Description

When you try to download a new version, while on the same session since another update, you can't download it because the .exe is in use.
This can be fixed by using random filenames, or using a temp folder.

#1

Updated by Per Amundsen almost 11 years ago

its a lot more complicated than that, and to fix this, you need to be very specific about where your adiirc is locate weither adiirc have write access to that folder or not, if your last update was completed and if adiirc was restarted.

also any error messages from debug.txt would be nice.

#2

Updated by Jeroen z0r almost 11 years ago

I updated AdiIRC, and after you pushed a new build I updated again.
It was unable to write to the file upp.exe

I did not (re)started AdiIRC and the task in task manger was upp.exe

I have rebooted since then, so my debug.txt is useless. :(

#3

Updated by Per Amundsen almost 11 years ago

  • Target version changed from 1.8.7 to 1.8.8
#4

Updated by Per Amundsen almost 11 years ago

  • Status changed from New to Closed

I think this is solved, it if happens again, let me know and i will digg further :)

Also available in: Atom PDF