Project

General

Profile

Bug #3202

WHOIS: Final param in RPL_WHOISCHANNELS handled incorrectly if not trailing

Added by Daniel Oaks over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
01/14/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hi Per,

I'm running into an issue where AdiIRC isn't interpreting the final parameter of a 319 (RPL_WHOISCHANNELS) message correctly when it's not a trailing param. I'm hoping that you'd be able to help me out, and hopefully can make AdiIRC more resilient going forward.

As noted in RFC1459 and all that, trailing (where the last parameter is prefixed with a ':') is just a syntactic trick to allow spaces/etc in parameters, and otherwise should be handled the same as any other parameter. However, it seems like AdiIRC's specifically looking for a trailing parameter on this 319 message, rather than just looking for "parameter 2".

I've got some raw IRC logs, and the respective display in the client to better show what I mean here:

Raw logs:

@time=2017-01-14T10:37:34.88Z :oragono.test 372 Dan :- This is the default Oragono MOTD.
@time=2017-01-14T10:37:34.881Z :oragono.test 372 Dan :- 
@time=2017-01-14T10:37:34.881Z :oragono.test 376 Dan :End of MOTD command
@time=2017-01-14T10:37:34.881Z :Dan!AdiIRC@127.0.0.1 221 Dan +
USERHOST Dan
JOIN #test
@time=2017-01-14T10:37:35.078Z :oragono.test 421 Dan USERHOST :Unknown command
@time=2017-01-14T10:37:35.079Z :Dan!AdiIRC@127.0.0.1 JOIN #test * Dan
@time=2017-01-14T10:37:35.079Z :oragono.test 331 Dan #test :No topic is set
@time=2017-01-14T10:37:35.08Z :oragono.test 353 Dan = #test @Dan!AdiIRC@127.0.0.1
@time=2017-01-14T10:37:35.08Z :oragono.test 366 Dan #test :End of NAMES list
MODE #test
@time=2017-01-14T10:37:35.279Z :Dan!AdiIRC@127.0.0.1 324 Dan #test +nt
@time=2017-01-14T10:37:35.279Z :Dan!AdiIRC@127.0.0.1 329 Dan #test 1484354255
whois Dam
@time=2017-01-14T10:37:43.092Z :oragono.test 401 Dam :No such nick
@time=2017-01-14T10:37:43.092Z :oragono.test 318 Dan Dam :End of /WHOIS list
whois Dan
@time=2017-01-14T10:37:45.897Z :oragono.test 311 Dan Dan AdiIRC 127.0.0.1 * Dan
@time=2017-01-14T10:37:45.897Z :oragono.test 319 Dan Dan @#test
@time=2017-01-14T10:37:45.898Z :oragono.test 317 Dan Dan 0 1484354254 :seconds idle, signon time
@time=2017-01-14T10:37:45.898Z :oragono.test 318 Dan Dan :End of /WHOIS list
JOIN #test2
@time=2017-01-14T10:37:50.907Z :Dan!AdiIRC@127.0.0.1 JOIN #test2 * Dan
@time=2017-01-14T10:37:50.907Z :oragono.test 331 Dan #test2 :No topic is set
@time=2017-01-14T10:37:50.907Z :oragono.test 353 Dan = #test2 @Dan!AdiIRC@127.0.0.1
@time=2017-01-14T10:37:50.907Z :oragono.test 366 Dan #test2 :End of NAMES list
MODE #test2
@time=2017-01-14T10:37:51.108Z :Dan!AdiIRC@127.0.0.1 324 Dan #test2 +tn
@time=2017-01-14T10:37:51.108Z :Dan!AdiIRC@127.0.0.1 329 Dan #test2 1484354270
whois Dan
@time=2017-01-14T10:37:56.719Z :oragono.test 311 Dan Dan AdiIRC 127.0.0.1 * Dan
@time=2017-01-14T10:37:56.719Z :oragono.test 319 Dan Dan :@#test @#test2
@time=2017-01-14T10:37:56.72Z :oragono.test 317 Dan Dan 0 1484354254 :seconds idle, signon time
@time=2017-01-14T10:37:56.72Z :oragono.test 318 Dan Dan :End of /WHOIS list

This log shows joining #test, doing a whois (and the channel not showing up), then joining #test2 and doing another whois (this time, the channels show up without an issue.

And I've attached a picture showing how it displays in the GUI.

Hopefully this is useful! Thanks very much for creating AdiIRC, looks like an awesome client. As a note, I'm running the 2.7 beta build (2017/01/01-2 64-bit).


Files

whois-adiirc.PNG (16 KB) whois-adiirc.PNG Daniel Oaks, 01/14/2017 01:46 AM

History

#1

Updated by Per Amundsen over 2 years ago

  • Category set to Interface
  • Status changed from New to Resolved
  • Assignee set to Per Amundsen

Yeah I sometimes am a little lazy when parsing, I have fixed this for next beta thanks, and thanks for the detailed report.

#2

Updated by Per Amundsen over 2 years ago

  • Status changed from Resolved to Closed
#3

Updated by Daniel Oaks over 2 years ago

No problem! Thanks for the resolution, it's very much appreciated.

Also available in: Atom PDF