Project

General

Profile

Bug #3513

closed

Frequent crashes when connected to channels with constant messages

Added by Kostas K over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
06/27/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
Windows 10
Regression:
No

Description

Using AdiIRC 2.8 x64 in win10.

I haven't found any relevant entry about the following issue neither in the AdiIRC beta changelog nor in issues, so I filed this.

The issue:
very frequently, when connected to channels with constant messages(5-10 messages per second) from XDCC bots, such as:
irc://irc.abjects.net:6667/moviegods
irc://irc.scenep2p.net:6667/THE.SOURCE
irc://irc.iarec.net:6667/ULTRA-WAREZ

then sooner or later, that channel window will crash, resulting in

and if I press 'Details' I get:

i.e.

Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index

Void ThrowArgumentOutOfRangeException(System.ExceptionArgument, System.ExceptionResource)

   at System.ThrowHelper.ThrowArgumentOutOfRangeException(ExceptionArgument argument, ExceptionResource resource)
   at AdiIRC.GUI.Elements.TextView.ScrollbarMeasureLines()
   at AdiIRC.GUI.Elements.TextView.OnScrollBarScroll(Object sender, EventArgs e)
   at System.EventHandler.Invoke(Object sender, EventArgs e)
   at System.Windows.Forms.ScrollBar.OnValueChanged(EventArgs e)
   at System.Windows.Forms.ScrollBar.set_Value(Int32 value)
   at AdiIRC.GUI.Elements.TextView.ScrollDown()
   at AdiIRC.GUI.Elements.TextView.OnMouseWheel(MouseEventArgs e)
   at System.Windows.Forms.Control.WmMouseWheel(Message& m)
   at System.Windows.Forms.Control.WndProc(Message& m)
   at AdiIRC.GUI.Elements.TextView.WndProc(Message& m)
   at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

And eventually, if I press 'Continue', then the current channel will become:

but I may keep on using AdiIRC (even thought the red "X" on that channel will keep on flashing).

I first thought that the 'Join-Part Filter.dll' plugin that I use is to blame,
but I unloaded it, restarted AdiIRC, and the problem continues to occur.

I have already submitted multiple crash reports of this (pressed the 'Send' button at the 'Sorry, AdiIRC crashed' window).

Thank you

#1

Updated by Per Amundsen over 3 years ago

  • Category set to Interface
  • Status changed from New to Assigned
  • Assignee set to Per Amundsen

I fixed a bug with that stacktrace earlier today, you might give it a try by typing /betaup (beta's are very safe), let me know if it helps.

Edit: Thanks for the detailed bug report.

#2

Updated by Kostas K over 3 years ago

Yes, the problem no longer appears. Thank you.

But, I noticed (in the beta, as well as in the stable version) this:
in such channels with non-stop messages, e.g. irc://irc.abjects.net:6667/moviegods
AdiIRC only displays something like the messages of the last 5-10 minutes at any time,
i.e. let's say I connect to the channel at 19:00,
well, after 20 minutes (at 19:20), the earliest displayed message in the window would be of 19:15 !

In mIRC this doesn't happen (it displays all messages, i.e. in the above case the earliest displayed message will be that of 19:00)

Why is that?
Is this controlled by some setting?

#3

Updated by Per Amundsen over 3 years ago

  • Status changed from Assigned to Resolved

Good to hear.

By default adiirc has a scrollback buffer of 500 lines, this can be changed per window in the Switchbar/Treebar right-click menu -> Buffer -> Select or globally in Options -> Messages -> Max buffer (setting it to 0 means unlimited).

I would not set this number to high since it will consume a lot of memory and will cause changing channel windows to use a lot of cpu and/or lag.

#4

Updated by Per Amundsen over 3 years ago

  • Status changed from Resolved to Closed
#5

Updated by Kostas K over 3 years ago

Thank you for the info. So, I'll not change that number.

I think I'll keep on using Beta.
Just one last question (hopefully not too obvious), please:
when saying:

beta's are very safe

I guess you mean that they are stable enough for everyday use, right?

#6

Updated by Per Amundsen over 3 years ago

You can change the number, maybe try 1000 see how it goes, if all good you can try 1500 etc.

Yes you can use it every day, I do so myself, some users get scared because it's called "beta", but they are actually more stable than "stable" since they have a lot of bug fixes which are not yet in "stable", like this one :>

#7

Updated by Kostas K over 3 years ago

Great!
Thanks once more for the quick responses!

Also available in: Atom PDF