Project

General

Profile

Actions

Bug #3542

closed

Applying theme fonts doesn't work

Added by Kostas K over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
07/06/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Using AdiIRC 2.9 beta 2017/7/6 x64 in win10.

AdiIRC by default uses the 'Default' theme.
I've noticed that any ASCII Art in the messages, is not displayed ok, not even when using the 'mirc' theme.

Screenshots/examples (both are server messages):
/server irc.opentrackers.org


vs in mIRC

/server irc.crackwatch.me:+6697

vs in mIRC

Also, I noticed yesterday while in a channel in the latter server,
that when someone pasted some ASCIII Art as message,
they were all displayed as "box/rectangle" characters (was ).
Here is the log (containing only the ASCII Art):
http://www.mediafire.com/file/t9b8svd328x8wxl/log.txt

It would be great if the ASCII Art would appear ok (as in mIRC).
(i.e. further improve the 'mirc' theme?)

Thank you

Actions #1

Updated by Per Amundsen over 5 years ago

It's all about the font you use, "themes" are just color themes, but some also set a custom font, make sure you are using a fixed width font such as Consolas.

Edit. AdiIRC uses "Verdana" as default font, it is not fixed width.

Actions #2

Updated by Kostas K over 5 years ago

Thank you!

So, I went in File|Options|Fonts,
clicked the: Font|'Messages'|'Browse' button, and in the "Choose font" window there I changed it from Verdana to Consolas.

Just one thing I noticed, regarding this:

just color themes, but some also set a custom font,

I've noticed that in the: Font|'Messages'|'Browse' button|"Choose font" window ,
the "Font" dropdown value remains "Verdana" in all cases (i.e. unless I manually change it to e.g. "Consolas"), no matter what theme I switch to.
e.g. if I switch (from the 'Default' theme) to the 'mirc' theme -----> as I saw, mirc.ini contains this line: "CONF_font=FixedSys 9"
then in the "Choose font" window, the Font value still remains "Verdana", instead of changing to "FixedSys".

And, if I tick the "Use Default" checkbox, then it restores to "Verdana",
but, then, it remains "Verdana" no matter what theme I switch to.

Shouldn't the displayed "Font" value be changed according to the currently used theme?
i.e. shouldn't it display the theme's used font, e.g. FixedSys, unless you have manually changed to a different font, e.g. Consolas?

Actions #3

Updated by Per Amundsen over 5 years ago

If a theme has a custom font and you check the "Apply Fonts" when applying a theme, the custom font will be overridden.

When you select "Use default" it will always revert to "Verdana" which is the default AdiIRC font.

If you reset theme to default, it will again use "Verdana" since it's the default AdiIRC font.

The "mirc" theme is very old, it's possible that adiirc doesn't pick up the old "CONF_font=" option, I'll check that.

Actions #4

Updated by Per Amundsen over 5 years ago

  • Subject changed from ASCII Art -- not displayed ok, not even using the mirc theme to Applying theme fonts doesn't work
  • Category set to Interface
  • Status changed from New to Resolved
  • Assignee set to Per Amundsen

I did some tests, and it seems the font are saved to the wrong section in the config file, probably happened after fonts where moved to "[Fonts]", I fixed this for next beta.

(Changing the topic to reflect the real issue)

Actions #5

Updated by Per Amundsen over 5 years ago

  • Status changed from Resolved to Closed
Actions #6

Updated by Kostas K over 5 years ago

Thank you for fixing this!

I just noticed this:

STR
in a clean 2.9 beta 2017/7/10 x64 installation (i.e. installing 2.8 and then typing /betaup ),
open AdiIRC (it will use the 'Default' theme)
and go to Options|Fonts (its main page).
It will be like this:

('Nicklist font weight' dropdown)| Prefix --> -
('Treebar font weight' dropdown) | Server --> -
('Links font weight') ----------------------> 'Underline' checked

Now (for the purpose of testing) go to File|Themes and switch to the 'Default' theme [and of course have all 10 checkboxes in the 'Apply theme' window checked].
Here is how the Fonts page will be:

('Nicklist font weight' dropdown)| Prefix --> -
('Treebar font weight' dropdown) | Server --> 'Bold' checked
('Links font weight') ----------------------> 'Underline' checked

i.e. the '('Treebar font weight' dropdown) | Server' now has the 'Bold' checkbox enabled.

Actions #7

Updated by Kostas K over 5 years ago

I have edited the previous post, making the STR as minimal as possible.

Actions #8

Updated by Per Amundsen over 5 years ago

Yeah the "Treebar font weight" for servers used to be bold, I fixed this for next beta, thanks.

Actions

Also available in: Atom PDF