Project

General

Profile

Actions

Bug #3599

closed

Text Wrap is not working inside a Dialog on Wine

Added by Acronix Anagami over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
07/21/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Example:

dialog wraptest { 
  title "Wrap Test" 
  size -1 -1 200 100 
  text "The quick brown fox jumps over the lazy dog over and over again", 1, 5 5 191 61
  button "&OK", 2, 72 75 55 22, ok default
}

then do:

/dialog -m wraptest wraptest

Actions #1

Updated by Per Amundsen over 5 years ago

Seems to work fine?

Actions #2

Updated by Acronix Anagami over 5 years ago

Hmm.. Probably just my setup. I'm on OSX 10.11.6 and running AdiIRC through winebottler. Build 7/15-2 32bit. It's not wrapping on my side.

Actions #3

Updated by Per Amundsen over 5 years ago

I setup a wine bottle and I see the same thing, it's reporting wrong size of the text for some reason, yet it doesn't seem to have a problem doing the exact same thing for the text-buffer.

Actions #4

Updated by Per Amundsen over 5 years ago

  • Subject changed from Text Wrap is not working inside a Dialog to Text Wrap is not working inside a Dialog on Wine
  • Status changed from New to Resolved

Some parts of Uniscribe seems to be wrongly implemented in Wine, I have created a workaround for now.

Actions #5

Updated by Per Amundsen over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF