Project

General

Profile

Bug #3701

/toolbar command only accepts .ico

Added by Mr. BS 3 months ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
08/29/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
Yes

Description

/toolbar -a GRbug GRbug blabla.png "/noop"

Tested same random interweb images (png/gif/bmp/etc) in AdiIRC/mIRC, all them failed on Adi. It returns * /toolbar: invalid image size.

Version tested: 3.0 Beta Build (2017/08/26).

Tell me if need further info.

works.png (296 Bytes) works.png Mr. BS, 08/30/2017 12:10 AM
fail.png (185 KB) fail.png Mr. BS, 08/30/2017 12:10 AM

History

#1

Updated by Per Amundsen 3 months ago

  • Status changed from New to Invalid

As you can see in #3693 and #3678, [x y w h] is a required parameter for non-icon images.

Example: /toolbar -a GRbug GRbug blabla.png 0 0 16 16 "/noop"

#2

Updated by Mr. BS 3 months ago

If you try my suggested command on mIRC, it works fine. Should we ignore that fact?

#3

Updated by Per Amundsen 3 months ago

I did, and it doesn't work "/toolbar: invalid image size".

#4

Updated by Mr. BS 3 months ago

hmm it seems mIRC is limiting supported images to some kind of aspect ratio or more likely by max dimensions. Try attached images.

/toolbar -a test test fail.png "/noop"

/toolbar -a test test works.png "/noop"

#5

Updated by Per Amundsen 3 months ago

That is possible,, I'll look into that.

#6

Updated by Per Amundsen 3 months ago

  • Status changed from Invalid to Resolved

It seems to be a max of 440 pixels in either direction, but there is also some aspect ratio involved, I made it a flat 440x440 before [x y w h] is required.

#7

Updated by Per Amundsen 3 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF