Project

General

Profile

Bug #3731

(during dcc transfers) if you minimize app to tray and restore, then for the first few seconds/minutes the progress bar will not be displayed in app icon in taskbar

Added by Kostas K about 1 year ago. Updated about 1 year ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
10/14/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Using AdiIRC 3.0 beta build 2017/08/31 x64 in win10.

During dcc file transfers, if Options|DCC|'Show progress in taskbar' is checked ,
AdiIRC will display progress bar in app icon in taskbar.

But, if you minimize AdiIRC to tray (via checking: Options|Tray Icon|either 'Send to tray on minimize' or 'Send to tray when pressing X (close button')) and then restore it,
especially when it's a large file, of many GBs,
then for the first few seconds/minutes the progress bar will not be displayed in app icon in taskbar. Then it's displayed again.

History

#1

Updated by Kostas K about 1 year ago

And an example:

I just started downloading a 15 GB file.
The speed was constantly ~1.5 MB/sec, which is the maximum possible for my adsl connection.
From the moment the download started, the progress bar initially appeared in taskbar after 1 min and 30 sec.
Then I minimized AdiIRC to tray, and immediately restored (tried it multiple times):
the progress bar wouldn't appear immediately, i.e. at the position it previously was - instead, every time it would appear in taskbar about 1 minute and 40 sec later.

#2

Updated by Per Amundsen about 1 year ago

  • Category set to Interface
  • Status changed from New to Resolved
  • Assignee set to Per Amundsen

After the window is restored, the progress bar would not be updated until the total percentage has changed, which could take some time for big files, I changed it to force update the progress on restore.

#3

Updated by Per Amundsen about 1 year ago

  • Status changed from Resolved to Closed
#4

Updated by Kostas K about 1 year ago

Thank you, but I just tried with the latest build (https://adiirc.com/build/AdiIRC64.exe),
i.e. tried (twice) minimizing to tray AdiIRC while downloading a 50 GB file (full speed, 1.5 MB/s),
and upon restore (via clicking the AdiIRC icon in the tray), unfortunately, the progress bar re-appeared in the app icon in taskbar (screenshot) :
after 6 minutes the 1st time, and after 7 minutes the 2nd time.

#5

Updated by Per Amundsen about 1 year ago

I was not able to reproduce, but I did some changes which hopefully fixed it, the build in the link is updated.

#6

Updated by Kostas K about 1 year ago

Yes, now it's fixed, thank you!

Also available in: Atom PDF