Project

General

Profile

Actions

Bug #3765

closed

AdiIRC menus (Alt + P) doesn't load correctly a custom menus.ini file

Added by Cassio Luz S. about 5 years ago. Updated almost 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
12/27/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Does't load correctly and doesn't save either.

Actions #1

Updated by Per Amundsen about 5 years ago

Do you have an example menu file that fails, and the steps you use to reproduce the issue?

Actions #2

Updated by Cassio Luz S. about 5 years ago

Per Amundsen wrote:

Do you have an example menu file that fails, and the steps you use to reproduce the issue?

If you go to "menubar" and try load a custom file, you will see that it doesn't load correct.

Also, if you modify config.ini [Misc] MenuFile= to a custom file, it doesn't work either.

Actions #3

Updated by Per Amundsen about 5 years ago

  • Category set to Interface
  • Status changed from New to Assigned
  • Assignee set to Per Amundsen

I looked into it, it seems some work was done to allow loading a custom menu file, but in miRC each menu section can have it's own file, this is not supported by the menu editor, so the work was halted.

Will look into it soon.

Actions #4

Updated by Cassio Luz S. about 5 years ago

Per Amundsen wrote:

I looked into it, it seems some work was done to allow loading a custom menu file, but in miRC each menu section can have it's own file, this is not supported by the menu editor, so the work was halted.

Will look into it soon.

I didn't give an example because i guess the issue isn't dedicated to a specific one. I guess that doesn't load correctly with a basic or a complex example, as far as i have seen. So i just said some steps.

Also, i tried to modify the config.ini [Misc] MenuFile= to a custom file, using the same default menus.ini model, but with only one difference: the content on menubar. It failed for me, but if it's an issue or not, i don't know.

Thanks.

Actions #5

Updated by Per Amundsen almost 5 years ago

  • Status changed from Assigned to Resolved

I have implemented loading of separate menus for each section for next beta, including the missing /load -p /reload -p parameters.

Actions #6

Updated by Per Amundsen almost 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF