Project

General

Profile

Bug #3766

closed

$asc() doesn't recognize "#"

Added by Cassio Luz S. over 2 years ago. Updated over 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
12/27/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No
#1

Updated by Per Amundsen over 2 years ago

  • Status changed from New to Invalid

This is not a bug, the # is evaluated to the current channel name (same as $chan) in mIRC scripting.

#2

Updated by Cassio Luz S. over 2 years ago

Per Amundsen wrote:

This is not a bug, the # is evaluated to the current channel name (same as $chan) in mIRC scripting.

And what about if someone needs to recognize "#" for something useful?

Example: if ($left($1,1) == #) { ... }

If my memory is correct, i guess it doesn't work on AdiIRC

#3

Updated by Per Amundsen over 2 years ago

It doesn't work in mIRC either, this feature was not designed by me.

However there are many ways to work around this, e.g if ($left($1,1) == $chr(35)).

#4

Updated by Cassio Luz S. over 2 years ago

Per Amundsen wrote:

It doesn't work in mIRC either, this feature was not designed by me.

However there are many ways to work around this, e.g if ($left($1,1) == $chr(35)).

When i tried to recognize "#" using the $asc(), i did want exactly to get the code and use the $chr()

Thanks

Also available in: Atom PDF