Project

General

Profile

Actions

Bug #437

closed

Channel sidebar stuck when using dual screens.

Added by RoestVrijStaal ~~~ over 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
10/31/2012
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello.

Today I decided to report an issue which I experienced earlier.

I'm often using my laptop in combination with a bigger screen. It works well on the screen of the laptop, however when I drag and maximize the AdiIRC window to the bigger screen, the entries in the channel sidebar aren't clickable anymore. The mouse pointer keeps holding the appearance of horizontal resizing and the horizontal resizing function.

Alt+Left/Right is a workaround, but it could be annoying when you've a lot of channels and queries open.

Please note that it doesn't occur when the AdiIRC window isn't maximized, for example when it has it's 'maximized size' of the smaller laptop screen.

I'm using 1.9.0 Build 271012-1

Actions #1

Updated by Per Amundsen over 10 years ago

is this the "View -> Sidebar" or just the regular "View -> Channelbar" dragged to the side ?

Actions #2

Updated by RoestVrijStaal ~~~ over 10 years ago

I meant the "View -> Sidebar"

I've turned off "View -> Channelbar" because I've so many things open that it doesn't fit in one line.

Actions #3

Updated by Per Amundsen over 10 years ago

I can't seem to be able to replicate this, but I don't have access to a laptop to test, I tried using dual monitors with different resolutions.

I'm wondering, are you able to click users in the userlist? Since the resize userlist and resize sidebar uses the exact same code.

Actions #4

Updated by RoestVrijStaal ~~~ about 10 years ago

When the Window is maximized on the second, bigger screen, I'm not able to click on the channel(s) nor user(s).
The same thing happens when i minimize the window and 'snap' the window on the left.

However when I minimize and place the minimized window on the center, or snap it at the right, it works.

Actions #5

Updated by Per Amundsen about 10 years ago

I made a few changes in the latest beta that might fix this, would you mind testing it ?

Thanks for helping me track down this issue :)

Actions #6

Updated by RoestVrijStaal ~~~ about 10 years ago

Today I tried out the latest Beta today but I had to rollback to the older beta because I get 'Arithmetic operation resulted in an overflow'-errors when I hovered over the sidebar on the left and userbar on the right. It doesn't matter on which monitor the AdiIRC Window is placed on.

Actions #7

Updated by RoestVrijStaal ~~~ about 10 years ago

I found out which version of the beta makes those errors. It's version 161112.

Actions #8

Updated by Per Amundsen about 10 years ago

Yes your right, I have uploaded a new beta that fixes this, sorry about that.

Actions #9

Updated by Per Amundsen about 10 years ago

The latest beta works for a friend of mine that is using a laptop + external monitor and had this problem, maybe it works for you to now ? :)

Actions #10

Updated by RoestVrijStaal ~~~ about 10 years ago

True, it works. But with a small cost: the width of the sidebars isn't adjustable anymore, so some of the channel names can't be fully on screen.

It's acceptable for me though. I don't have much problems with it.

But I could imagine that if someone joins for example #adiirc-talk and #adiirc-bugs, that it could be tricky.

Thanks anyway :)

Actions #11

Updated by Per Amundsen about 10 years ago

damn, its still not calculating correctly then, ill continue digging :)

Actions #12

Updated by Per Amundsen about 10 years ago

Could you please run this test app https://dl.dropbox.com/u/18303/Mousetest.exe first on the first monitor, copy paste the text, then run it on the second monitor and copy paste the text, and also could you please tell me the different resolutions?

Would really help :)

Actions #13

Updated by RoestVrijStaal ~~~ about 10 years ago

I was a bit goofing out how I had to use that test app. I noticed that the text area gets only values when putting the mouse in the red area.

I didn't know where to place my mouse pointer in the area so I just took the values of the upper right corner of the it. Sidenote: I maximized the window of the testapp because I didn't know where to place it on the screen.

My first screen - 1280 x 800
32bit
X = 99
Y = 27

X2 = 99
Y2 = 27

64bit
X = 99
Y = 27

X2 = 99
Y2 = 27

Relative
X = 99
Y = 0

=====

My second screen - 1920 x 1080

32bit
X = -217
Y = -1053

X2 = 65319
Y2 = -1053

64bit
X = -217
Y = -1053

X2 = 65319
Y2 = -1053

Relative
X = 99
Y = 0

Actions #14

Updated by Per Amundsen about 10 years ago

Sorry, I forgot to explain what to do, my bad, I just needed a mouse sample from both screen in the red area, you were suppose to get a mouse resize grip between the red and the gray to simulate sidebar resize.

Your tests seems consistent with my tests, if i'm right, resizing sidebar should work correctly in the newer betas, would you mind testing it out?

Thanks again for your help :)

If it dosent work, I should be able to replicate your monitor setup now :)

Actions #15

Updated by RoestVrijStaal ~~~ about 10 years ago

Unfortunately it doesn't work in the latest beta ( 080113 ) nor I experienced working in the previous betas...

Actions #16

Updated by Mark Childs about 10 years ago

FYI: I was having this issue and it was driving me crazy! Seems to be fixed for me with beta (310113-1).

Thanks so much!

Actions #17

Updated by RoestVrijStaal ~~~ almost 10 years ago

Sorry for the late reply.

I could indeed conclude that this bug is fixed. The version of AdiIRC i use when writing this is 1.9.0 Beta Build (270313).

Actions #18

Updated by Per Amundsen almost 10 years ago

  • Status changed from New to Resolved

Happy to hear that, finally! :)

Actions #19

Updated by Per Amundsen almost 10 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF