Project

General

Profile

Bug #5072

closed

$address/$fulladdress does not fetch user@host from :source on RAW CHGHOST

Added by Koragg KnightWolf about 2 months ago. Updated 18 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
06/15/2020
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

When attempting to make use of RAW CHGHOST it is not possible to fetch the :source user@host via the $address identifier. Other IRCv3 RAW's such as RAW INVITE and RAW ACCOUNT work as expected though. Interestingly $rawmsg DOES get the :source nick!user@host (the "old" one before CHGHOST broadcasts the "new" one). Perhaps AdiIRC is thrown off because there is two user@host at times or two hosts (RAW CHGHOST can apply to just the hostmask or to user@host both are possible). Workaround employed:
RAW CHGHOST:*: {
var s %full = $gettok($gettok($rawmsg,1,32),2,33)
var -s %ident = $gettok(%full,1,64)
var -s %host = $gettok(%full,2,64)

Then making use of %ident $+ $chr(64) $+ host to get the "old" user@host to be displayed.


Files

chghost.txt (3.49 KB) chghost.txt Koragg KnightWolf, 06/15/2020 12:34 AM
#1

Updated by Per Amundsen 18 days ago

  • Subject changed from $address does not fetch user@host from :source on RAW CHGHOST to $address/$fulladdress does not fetch user@host from :source on RAW CHGHOST
  • Category set to Scripting
  • Status changed from New to Resolved
  • Assignee set to Per Amundsen
  • Operative System changed from Windows 10 to All

Fixed in next beta.

#2

Updated by Per Amundsen 18 days ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF