Project

General

Profile

Bug #5175

closed

Empty/blank taskbar icon after updating Windows 10 October 2020 update (20H2)

Added by Kostas K 12 months ago. Updated 12 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
10/26/2020
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

After updating Windows 10 to October 2020 update (20H2) from version 2004 (20H1)
I noticed that its taskbar icon is now empty/blank at windows startup (AdiIRC is set to autostart with windows):

It only appears empty/blank initiallly, on windows startup: if I close+restart AdiIRC then its taskbar icon appears ok.
I also tried fully uninstalling AdiIRC (incl.settings) + reinstalling it but the issue remains.
Using latest AdiIRC 4.0 beta x64 build 2020/09/30.

PS. Maybe it's not an issue with AdiIRC but a Windows issue?
But, I haven't noticed this issue with any other program.

#1

Updated by Per Amundsen 12 months ago

  • Category set to Interface
  • Status changed from New to Invalid
  • Assignee set to Per Amundsen

This is a windows issue and I have seen it happening with many programs, specially iTunes.

I suspect it is caching a blank icon somewhere, maybe try clean your explorer thumbnail cache and/or windows temp files.

A quick google also found this https://answers.microsoft.com/en-us/windows/forum/windows8_1-performance/how-to-fix-taskbar-icons-that-look-like-white/408e21b3-2da5-4b78-a204-b704e4a23af4

#2

Updated by Kostas K 12 months ago

Thank you for replying.

I followed the steps and unfortunately the issue remains.
However, I just did the following:

  • as AdiIRC is running, rightclick on the blank statusbar icon, then rightclick again on the top displayed 'AdiIRC' entry (it's actually this shortcut file: C:\Users\Kostas\AppData\Roaming\Microsoft\Windows\Start Menu\Programs\AdiIRC.lnk) and click "Properties"
  • now in 'Shortcut' tab, click on the "Change icon" button:
    it shows a "Change Icon" window saying: Windows can't find the file %USERPROFILE%"\AppData\Local\Temp\AdiIRCIcon.ico :

So, I clicked the "Change icon" button again, and changed its path to "C:\Program Files\AdiIRC\AdiIRC.exe", selected the listed icon and the issue is now fixed.

 

Maybe this situation occured during a AdiIRC beta update??
I'm saying this because, a few times Windows Defender has wrongly found a beta update as "threat", (I've noticed that AdiIRC uses USERPROFILE"\AppData\Local\Temp to download a file which then replaces AdiIRC.exe)
and then I have to whitelist+restore it in Windows Defender, for the update to complete.
Maybe in such cases the file that AdiIRC downloads in Temp, becomes eventually removed/missing from the Temp folder, and so AdiIRC doesn't have an icon in taskbar on Windows launch?

#3

Updated by Per Amundsen 12 months ago

it's possible that windows refused to load the icon from the exe file when it was flagged and instead used a plain icon in it's place which is now cached somewhere, clearing the windows icon cache should fix such issues, I'm not exactly sure how that is done.

You'll have to ask someone who knows more about windows than me, maybe ##windows on freenode.

Also available in: Atom PDF