Project

General

Profile

Actions

Bug #5502

closed

Log files not showing after save?

Added by eahm eahm 4 months ago. Updated 3 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
02/25/2022
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Not sure it's a bug or I'm doing something wrong, right click channel > buffer > save as > logs folder > open Tools>Logs > empty.

I don't normally log so I just noticed but I can't seem to make AdiIRC show the log files (.log). Is there anything I'm missing?

Thanks.

Actions #1

Updated by Per Amundsen 4 months ago

Make sure your are saving and searching the same folder.

Actions #2

Updated by eahm eahm 4 months ago

Dude

Actions #3

Updated by Per Amundsen 4 months ago

Don't "dude" me, people makes mistakes all the time and the first thing to check is the simple things.

Also I am not able to replicate this, it works fine saving and searching the same folder.

Actions #4

Updated by eahm eahm 4 months ago

Yes I get it but the folder is the correct one, for saving and when searching, not sure why I can't see any logs saved manually still, I can share my config file if you'd like to try?

Under Logging, the "Files names?" tab should be "File names" or that was on purpose? That way it looks like every other tab could have the "?", just a thought.

Actions #5

Updated by Per Amundsen 4 months ago

I am still considering what to call it, I will decide before next stable version.

There are no log options used in the logs dialog besides last searched patterns, all I can think of is delete the filename pattern and the search pattern, and retype the filename pattern in case there are some invisible character(s) or something, I have seen that happen before in other places.

Don't have any other ideas atm.

Actions #6

Updated by eahm eahm 4 months ago

I turned on auto logging of Chans, Server and Queries and I see AdiIRC creates all the folders with server names and dates and it creates log files under those BUT the Logs dialog still doesn't show any log in the list. I tried to enter the address, browse the Logs folder and type .\Logs, nothing makes it work.

Using the latest Beta 64 bit, Windows 10 LTSC 2021.

Actions #7

Updated by eahm eahm 3 months ago

I tried again after I looked here https://dev.adiirc.com/projects/adiirc/wiki/Logs_Dialog and let me tell you, I had no idea I had to enter *.log, that's supposed to be automatic no? AdiIRC logs on .log files so... not sure, your call, I was even trying to look for chans and queries names etc.

I saved it on config.ini so now the *.log is there every time I open the dialog.

mIRC shows the logs automatically but maybe you like it more this way not sure.

All good, this ticket can be closed now.

Actions #8

Updated by Per Amundsen 3 months ago

  • Status changed from New to Invalid

Obviously *.log is there by default, you can verify this by copying AdiIRC.exe to a new folder with no config file.

You must have accidentally deleted the filename pattern at some point.

Actions #9

Updated by eahm eahm 3 months ago

You must have accidentally deleted the filename pattern at some point.

Confirmed to be the case. Thanks for checking and sorry for the trouble.

Actions

Also available in: Atom PDF