Project

General

Profile

Actions

Bug #5618

closed

Duplicate submenu items

Added by Kenggi Peters 5 months ago. Updated 4 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
09/11/2022
Due date:
% Done:

0%

Estimated time:
Operative System:
Windows 10
Regression:
No

Description

WHen you create your popup layout in the menus.ini your get duplicate menu items because all menu items with submenu items get duplicated. You should be able to layout all menus with sub-items and menu separators (hyphen) by putting the sub-items in the remotes section and sub-menus in both the popups and the remotes.

Actions #1

Updated by Per Amundsen 5 months ago

Can you give an example? What does mirc do with the same example?

Actions #2

Updated by Kenggi Peters 5 months ago

In mIRC when you create your popup menu you do not include the menu items, just the menus and submenus. In the remotes you include all the menus, submenus and items. In case the remotes is loaded out of order for some reason your popup menus will not be out of order because you have the layout in popups. With Adiirc when you create your layout in the menus.ini (popups) and in the remotes you end up with duplicate menus and sub-menus. The only time you should get duplicates is when you create menu-items (clickable functions) in both popups and remotes but never with menus or sub-menus. Now I need to create a separate menus.ini for Adiirc; and another (popups.ini) for mIRC.

-+-+--+-+-+-+++-+-
Example for Popups:
-+-+--+-+-+-+-+-+-

Named &Bauder
-
&Another Menu

-+-+--+-+-+-+-
Example in Remotes.ini
-+-+--+-+-+-+-+-

menu status,channel {
named &Bauderr
.describe &script : /ame is celebrating a big surprise; s/he is using an Adiirc script
&Another Menu
.&echo something : /echo -as This menu item has no separator (hyphen) in remotes, however it does have it in popups.

}

Actions #3

Updated by Per Amundsen 5 months ago

This is not correct, you can have multiple menu items with the same names in mirc, you can also full create a menu in either the popup or in the remote script or mix them, that is why I am asking for an example that reproduces the problem so I can test for differences.

Copy AdiIRC.exe to a empty folder somewhere, run AdiIRC from that folder, what do I type into "Edit Menus" and "Edit Scripts" that reproduces the problem?

Actions #4

Updated by Per Amundsen 5 months ago

Sorry the example was not visible at first for some reason, I see it now.

I can reproduce with this example, I'll look into it.

Actions #5

Updated by Per Amundsen 5 months ago

After a closer look, this seems to work as expected, the "Named &Bauder" menus are not merged because they are not named the same: "Named &Bauder" vs "named &Bauderr" there is an extra "r" at the end, this produces the same result in both mirc/adiirc as far as I can see.

Changing the name so they are both "named &Bauder" fixes the merge in both clients.

Do you have an example that produces a difference in mirc/adiirc?

Actions #6

Updated by Per Amundsen 4 months ago

  • Status changed from New to Invalid
Actions

Also available in: Atom PDF