Project

General

Profile

Actions

Bug #929

closed

Only rejoin one channel upon reconnect

Added by PQ allo almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Irc
Target version:
Start date:
12/10/2013
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

When I get disconnected and I want to reconnect to the server I only rejoin 1 channel instead of all channels I was in before I got disconnected

Happening since last update some days ago. 1.9.2

Actions #1

Updated by Per Amundsen almost 9 years ago

I'm not able to reproduce this, could you elaborate a little, is it a quick connect server or a server from the server list, are the channel windows open or closed before you reconnect, and also how do you reconnect, by typing /reconnect or clicking the connection icon?

Actions #2

Updated by PQ allo almost 9 years ago

Per Amundsen wrote:

I'm not able to reproduce this, could you elaborate a little, is it a quick connect server or a server from the server list, are the channel windows open or closed before you reconnect, and also how do you reconnect, by typing /reconnect or clicking the connection icon?

I usually put my laptop on standby at the night, when I open it again it used to reconnect automatically to all channels. It's only reconnecting to 1 channel now.

I just tested this by disconnecting with the button and reconnecting with the button, gives the same problem. Disconnecting with the command and reconnecting with the command give the same problem as well.
All channel windows are still open.
It's a server that's in my server list with connect on startup enabled and has a list of channels it should autojoin. It does join all the channels when I open AdiIRC or start a new server window.

My autojoin channel list is like this: "#channel1 password1, #channel2, #channel3, #channel4, #channel5 password2, #channel6 password3, #channel7 password4, #channel8 password5"
I just tried removing all channels with password and that did get me to rejoin all 3 non-passworded channels on reconnect. So the problem seems to be with the passworded channels. (although the only channel I reconnected before was the passworded channel1 (when I removed channel1 it connected to channel5 only, it always connects the passworded channels first for some reason)

Actions #3

Updated by Per Amundsen almost 9 years ago

Ah I see, thanks, I'll fix that.

Actions #4

Updated by Per Amundsen almost 9 years ago

  • Category set to Irc
  • Status changed from New to Assigned
  • Assignee set to Per Amundsen
  • Target version set to 1.9.3
Actions #5

Updated by Per Amundsen almost 9 years ago

  • Status changed from Assigned to Resolved

Fixed in next beta, gonna upload it in a while, you can type /betaup to get it :)

Actions #6

Updated by Per Amundsen almost 9 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF