Project

General

Profile

Joins/quits not showing up like they're supposed to [SOLVED]

Added by Magnus v G K 23 days ago

I switched over to AdiIRC from mIRC about half a year ago, and while I've enjoyed it, for some reason I have this lasting issue of joins and quits not showing up anywhere at all. Not displaying in the wrong channel—they're not displaying at all, anywhere, no matter my settings. The problem was still there after the March update to the client, and I just do not understand it.

These are my general Events settings.

These are my specific Events settings for two channels on two different servers.

But for both of those channels and servers, I don't get any join or quit messages in any window. Not in the channel window, not in the status window, not anywhere.

There are some other Events messages that I'm fairly sure aren't showing up like they're meant to, too—nick changes, for instance—but joins and quits have been the most noticeable.

I am using a custom theme that I put together myself, is there any possibility that has anything to do with it? In the preview in the themes menu, the example event messages are visible.

At this point I'm just grateful for anything that might bring me closer to figuring out what the heck.


Replies (5)

RE: Joins/quits not showing up like they're supposed to - Added by Per Amundsen 23 days ago

Are you using any plugins or scripts? if so, try disable them.

if by custom theme, you mean MTS themes, please post it here.

RE: Joins/quits not showing up like they're supposed to - Added by Magnus v G K 23 days ago

No plugins, and no scripts.

Adding my theme here. It's a theme I made only for personal use with no real intent to share elsewhere, and was kinda cobbled together by first copying another theme file and then changing colours and editing variables until I got it the way I wanted, looking at other theme files to figure out how things worked. So it's not impossible that I might have messed something up somewhere.

Kenny.ini (4.62 KB) Kenny.ini

RE: Joins/quits not showing up like they're supposed to - Added by Per Amundsen 23 days ago

Okay that is not a MTS theme, just regular color which you can change in Options -> Colors.

I verified that join/part/quit etc shows up in the status window with your event settings and your theme.

Next time there is a join/part/quit which doesn't show up, check Menubar -> File -> Rawlog and look in the Debug tab for any related errors.

It's also possible there is some specific combinations of options causing this (adiirc has too many options), if possible can you email me a copy of your config.ini file to ?

Remove any personal information from config.ini if necessary, although if you could just keep one of the [SavedWindows] entries where the join/part/quit messages are broken and just rename the channel to #channel and network name to network, that would be great, in case the per window options is somehow bugged.

Also check for duplicate channels in the [SavedWindows] entries.

RE: Joins/quits not showing up like they're supposed to - Added by Magnus v G K 23 days ago

...and I just figured out the entire problem. I'm getting the joins and quits in the proper windows now.

When looking through my config.ini in preparation to send you a copy, I saw one little line that gave me pause. So I went to Options -> Messages, and in there I had checked the box that said "Only show join, parts, quits, nick from active users". So it seems that the problem consisted entirely of me and AdiIRC disagreeing about what "active user" means.

Still, thanks for the help—talking about the problem, describing it to someone else and trying suggested solutions, was definitely helpful in getting me to notice something I was sure I had already looked at.

RE: Joins/quits not showing up like they're supposed to - Added by Per Amundsen 23 days ago

Ah right, forgot about that option, that does explain it, glad you figured it out.

    (1-5/5)