Project

General

Profile

Bug #3271

/dialog not display an error in tab case

Added by westor (GR) over 2 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
02/04/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

When i use /dialog -md testing testing in order to open this dialog it didn't open and it also didn't receive any error message, the currently error is because i set 'tab 1' that i didn't create tabs inside the dialog setup, but in this case it should return an error because the dialog did never opened.

Test code:

dialog testing {
  title "test" 
  size -1 -1 233 108
  option dbu disable
  list 3, 4 30 99 47, tab 1 size vsbar disable
}

History

#1

Updated by Per Amundsen over 2 years ago

  • Status changed from New to Resolved

There used to be a error, but the error display broke in some places last beta due to rewrites, I have fixed that for next beta.

And using tab N without a tabcontrol is also allowed now.

#2

Updated by Per Amundsen over 2 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF