Project

General

Profile

Actions

Bug #3559

closed

Custom menus should not trigger when right click a link

Added by westor (GR) over 5 years ago. Updated over 5 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
07/08/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I saw that when using right click into a link and i have a custom menu created it also display that menu into that right click list
as it should not be displayed, in few words the "*" prefix into the menu effecting the right click into links.

Examples:

menu * {
  Menu $menu:noop
}

- Thanks!

Actions #1

Updated by Per Amundsen over 5 years ago

in AdiIRC links are scripted menus just like channel menus, using "*" will show the menu in links as well.

Actions #2

Updated by westor (GR) over 5 years ago

That one only triggers if i right click a link into the status windw, if someone post a link into a channel and i right click into it, it doesn't appear.

Actions #3

Updated by Per Amundsen over 5 years ago

Okay that is a bug, it should shown in all, I'll look into that.

Actions #4

Updated by westor (GR) over 5 years ago

Aha ok, it's something extra that is good that is being supported, it would be nice if that was attend into the help file under "Menus" tab.

- Thanks!

Actions #5

Updated by Per Amundsen over 5 years ago

I cannot replicate any issues, it shows the "menu *" when clicking links in status/channel/query/custom as expected.

Actions #6

Updated by Per Amundsen over 5 years ago

  • Status changed from New to Rejected

I updated the menu wiki with the new menu types, also I suggest always use the wiki since the help file must be manually updated is usually only done 2-4 times a year when a new stable is released.

Actions

Also available in: Atom PDF