Project

General

Profile

Actions

Bug #3657

closed

{ } curly brackets is not always parsed correctly

Added by westor (GR) over 5 years ago. Updated over 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
07/31/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

There is an odd bug, If you create an file and place the below code and execute the $isalias() to check if that alias exist it returns $false for an unknown reason.

Example Code: (Full code url: http://www.mpaste.com/p/EorVuOi)


alias test1 { return 1 }

alias -l jfm_jscript {
  jfm_badd $1 H.prototype={  
}

alias test2 { return 2 }

When executing : //echo a IS: $isalias(test1) - $isalias(test2) the "test2" alias flagged as $false but it shouldn't because exists.

- Thanks!

Actions #1

Updated by Per Amundsen over 5 years ago

  • Subject changed from $isalias() return $false incorrectly sometimes to { } curly brackets is not always parsed correctly
  • Description updated (diff)
  • Status changed from New to Resolved

Not related to $isalias, I updated the example and title to reflect the real issue.

Actions #2

Updated by Per Amundsen over 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF