Project

General

Profile

Actions

Bug #3669

closed

Checking for brackets sometimes returns a warning errorous

Added by westor (GR) over 5 years ago. Updated over 5 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
08/05/2017
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I was trying to create a code and when i checked for brackets (CTRL +h) then the adiirc occurred me an warning error but it hasn't any errors, i was trying to debug the ascii characters and compare them with mIRC and the results are different, as i see the mIRC strips some ascii characters when doing checking brackets and fit the code in the correct position, i will provide you some examples to see and may reproduce the issue, but i was trying the into an other AdiIRC client (32bits) and i couldn't reproduce it clearly, but i report it in the case of you can understand where is the bug exactly.

Code: http://www.mpaste.com/p/J0I

ASCII numbers differences when pressing CTRL+h to fit the correct position:

mIRC:

AdiIRC:

- Thanks!

Actions #1

Updated by westor (GR) over 5 years ago

Here is the hole file that this issue occurred: http://a.pomf.cat/tzmajb.ini

Actions #2

Updated by Per Amundsen over 5 years ago

  • Category changed from Interface to Scripting
  • Status changed from New to Invalid

I tested this in both mIRC and AdiIRC, and both shows an error, because there is a vertical tab character (11) in front of "var %l".

Actions

Also available in: Atom PDF