Project

General

Profile

Bug #3845

$nickcolor not working in prefixuser

Added by kel po over 1 year ago. Updated over 1 year ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
03/19/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hi,

the variable $nickcolor is not working in the Message prefix -> User textbox


Files

nickcolor.PNG (51.7 KB) nickcolor.PNG kel po, 03/19/2018 04:35 PM

History

#1

Updated by Per Amundsen over 1 year ago

It only works if you have set a nickcolor for that nick or using random nickcolors, it does not work for extended (rgb colors), $rgbnickcolor must be used for them.

#2

Updated by kel po over 1 year ago

i have a nickcolor set, please see the attached screenshot

#3

Updated by Per Amundsen over 1 year ago

First of all, that is not how to use $nickcolor, $nickcolor returns the color number associated with the nick, nick colors must be enabled in Options -> Nick Colors, and there must be either a rule for the nick or random nick colors must be enabled.

If you only want the nick to be colored, you don't need to use $nickcolor, once nick colors are enabled the $pnick variable will already have the color.

A typical use case for $nickcolor is to allow coloring more than just the nick, something like <nickcolorchar>$nickcolor[$nick]<nickcolorchar>, in this case [nick] will be colored using the nick color, instead of just the nick.

#4

Updated by Per Amundsen over 1 year ago

  • Status changed from New to Invalid

I updated the Options -> Messages -> Message prefix User wiki, hopefully it makes it more clear how it works.

The default prefix is <$pnick>: btw, you should use $pnick unless you want to manually create a prefix like in the wiki examples.

Also available in: Atom PDF