Project

General

Profile

Bug #3905

/download stucks in some cases

Added by westor (GR) 6 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
05/23/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I'm using the latest Windows 10 update and the latest AdiIRC beta version online, i am trying to download some multiple files from a host server but the most of them doesn't downloading, i don't know why this is happening, i checked my internet connection and seems good, also i checked the server side and was ok too, here is an short code example to reproduce it.

Example Code:

alias test_download {
  var %url = http://westor.ucoz.com/wmm/modules.json
  var %d = $envvar(temp) $+ \

  var %t = 10
  var %i = 1
  while (%i <= %t) {
    download -o test_ $+ %i %url $qt(%d $+ file_ $+ %i $+ .json)
    inc %i
  }
  echo -a finshed!
}

- Thanks!

2018-05-24_00-01-32.mp4 (2.81 MB) 2018-05-24_00-01-32.mp4 westor (GR), 05/23/2018 11:21 PM

History

#1

Updated by Per Amundsen 6 months ago

Seems to work fine, you can use the on DOWNLOAD event to check $downloaderr for any problems.

on *:DOWNLOAD:test_*:echo -ag Download of $download($download).file complete, status is $iif($downloaderr,Error $v1,Okay)
#2

Updated by westor (GR) 6 months ago

I've restarted my computer and now it seems to be ok, it may was an windows issue that was only downloading some of the queue downloads, i will provide you the video that i took before the restart just in case it is something from adiirc side, thanks for response.

#3

Updated by Per Amundsen 6 months ago

The downloading is pretty simple, just one line of code to tell the .NET framework to download a file by url and a filename it should save to, there is not much room for error.

From the video it seems more likely to be a network issue, the first file download seems ok, the second file download throws an error and after that the remaining downloads is stalled, probably because they can't connect and are waiting to timeout or similar.

For next beta, I'll change the $downloaderr to return the error message from the .NET exception instead of just "1", should give you more clues.

#4

Updated by westor (GR) 6 months ago

Thanks, an error message of course would be something more for catch up, by the way i wanna ask what is the default timeout value when starting an downloading connection?

#5

Updated by Per Amundsen 6 months ago

Google says between 30 and 100 seconds.

#6

Updated by Per Amundsen 5 months ago

  • Status changed from New to Resolved
  • Target version changed from 3.1 to 3.2

The timeout is not fixed 30 seconds.

#7

Updated by Per Amundsen 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF