Project

General

Profile

Actions

Bug #3929

closed

$ulist doesn't working when level is not a number

Added by westor (GR) over 4 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
06/05/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

There is a bug into the $ulist identifier that it doesn't trigger in some situations because the level contains numbers (as i could reproduced), here are some examples to reproduce.

Not Working Examples:

//auser test_level test_nickname | echo -a IS: $ulist(test_nickname,test_level,1) | ruser test_level test_nickname
//auser test_level test_nickname | echo -a IS: $ulist(*,test_level,1) | ruser test_level test_nickname

-

Working Examples:

//auser 50 test_nickname | echo -a IS: $ulist(test_nickname,50,1) | ruser 50 test_nickname
//auser 50 test_nickname | echo -a IS: $ulist(*,50,1) | ruser 50 test_nickname

- Thanks!

Actions #1

Updated by Per Amundsen over 4 years ago

  • Status changed from New to Resolved
Actions #2

Updated by Per Amundsen over 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF