Project

General

Profile

Bug #3949

$sock().ip returns incorrect values before socket opens

Added by westor (GR) 5 months ago. Updated 5 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
06/15/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

There is an issue with ".ip" property in $sock() that when you try open a socket and then immediately echo the $sock().ip it returns invaild parameter, it should return the ip/address that you specified to open the socket.

But and this situation if you specify an ip address to open $sock().ip should return that ip instead of that ip that returns now, so this one is bug.

Example:

//sockopen test adiirc.com 80 | echo -a IS: $sock(test).ip | sockclose test
; this should return "adiirc.com" instead of 192.168.1.4 that returns now, because the DNS didn't finish to get the domain ip to return the correct one.

//sockopen test 138.201.220.190 80 | echo -a IS: $sock(test).ip | sockclose test
; this should return 138.201.220.190 instead of 192.168.1.4 that returns now, because the DNS doesn't play a role here as you have already specified an IP on opening parameter.

- Thanks!

History

#1

Updated by Per Amundsen 5 months ago

  • Status changed from New to Resolved
  • Target version changed from 3.1 to 3.2
#2

Updated by Per Amundsen 5 months ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF