Project

General

Profile

Bug #3967

$dns() returns wrong values during simultaneous dns requests

Added by westor (GR) 21 days ago. Updated 20 days ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
06/27/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I am trying to create a code (DNSBL) that will perform a massive dns progresses lookup, but i catch a bug that ON DNS event it doesn't return correctly the $dns() results while looping into the queue, that making first slowly and not working propertly, i will provide a test code to run it and reproduce it.

Example Code: (use /test_dns multi times because it using random ips for scan)

ON *:DNS: {

  echo 2 -sg DNS: $dns(0) -- $dns(0).ip -- $dns(0).addr

}

alias test_dns {
  var %i = 1
  while (%i <= 30) {
    var %ip = $rand(100,200) $+ . $+ $rand(100,200) $+ . $+ $rand(100,200) $+ . $+ $rand(100,250)
    dns -4 %ip
    inc %i
  }
}

- Thanks!

History

#1

Updated by Per Amundsen 20 days ago

  • Status changed from New to Resolved
#2

Updated by Per Amundsen 20 days ago

  • Subject changed from ON DNS doesn't loop on queue correctly to $dns() returns wrong values during simultaneous dns requests
  • Status changed from Resolved to Closed

Also available in: Atom PDF