Project

General

Profile

Bug #3990

closed

AdiIRC returns incorrect line number on scripting error on menus editor

Added by westor (GR) over 3 years ago. Updated over 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
07/07/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

There is a bug, when i was trying to edit some from the default menus in AdiIRC and made a mistake when i right click on Status Window it returns an error message that the error line number was errorous, in the following example the error it seems to be in line 8 but adiirc returns line 163.

Image Example:

- Thanks!


Files

AdiIRC_2018-07-07_01-44-45.png (35.7 KB) AdiIRC_2018-07-07_01-44-45.png westor (GR), 07/07/2018 12:47 AM
#1

Updated by Per Amundsen over 3 years ago

That's because all the menus are in the same file, the line number is the true line number in the file not in the menu editor.

#2

Updated by westor (GR) over 3 years ago

Ah didn't know that, that's because in the menus.ini including all the menus, correct.

#3

Updated by Per Amundsen over 3 years ago

  • Status changed from New to Invalid

Also available in: Atom PDF