Project

General

Profile

Bug #4004

closed

$modes doesn't return the correct channel modes order on windows titlebar

Added by westor (GR) over 3 years ago. Updated over 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
07/07/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

There is a bug, when i use $modes identifier to view the channel modes of the channel window in titlebar the order seems to be incorrect.

Options sets value:

$channel [$modes] - OPs: $ops - HalfOPS: $halfops - Voices: $voice - Normal: $normal - Total Users: $users

Options sets image:

Titlebar while target is a channel window:

The [$modes] should return [+ntrCTj 3:5] instead of [+CjnrtT 3:5]

- Thanks!

#1

Updated by Per Amundsen over 3 years ago

The order is correctly sorted same as $chan(#).mode.

Edit. Also same as Menubar -> Window.

#2

Updated by westor (GR) over 3 years ago

For some reasons $chan($chan).mode doesn't return the correct channel modes as /mode #chan returns, but this seems to be the same action and on mIRC that is strange. i will do a research about why this is happening, it should return +ntrCTj 3:5 on $chan($chan).mode .

#3

Updated by Per Amundsen over 3 years ago

It returns the correct result in both clients, it's sorted alphabetically.

/mode #chan probably returns in the order the modes was set.

#4

Updated by Per Amundsen over 3 years ago

  • Status changed from New to Invalid

Also available in: Atom PDF