Project

General

Profile

Bug #4021

AdiIRC seems not sending WHO or WHOX command on join by default in some cases

Added by westor (GR) 4 months ago. Updated 4 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
07/11/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I saw that when i joined into a channel into Freenode (only that network i can reproduce this issue) it seems that it doesn't sending an silent /WHO #CHANNEL (or /ialfill) to fill the IAL with nicknames + addresses on that channel.

Steps to reproduce: join into a channel (e.g: #windows that is large) on freenode and then try to get an random nickname address (//echo -a IS: $address(nick,0) to see).

Also something related to that feature to finalize the support of IAL on AdiIRC (as now it is 90% ready) that i think is important feature, it would be nice to see /ial + /ialclear + /ialfill commands to be also supported so we can make our codes to work in AdiIRC too. (sorry for this note i know that is something extra, ignore it if bothering).

- Thanks!

History

#1

Updated by Per Amundsen 4 months ago

AdiIRC does not send a /who or /whox to any channel because it generates a lot of traffic, the only case where adiirc sends a /who is when "Track away status" is enabled.

Instead AdiIRC relies on https://ircv3.net/irc/#userhosts-in-names and monitoring whois/joins/messages/mode changes and so on.

I checked in mirc and it doesn't seem to send who by itself either, you probably were lucky that the user you checked with $address was already in the list or you have a script that does /who,

There is no need for /ial and /ialclear in adiirc since there is always a ial list and it's always updated when it sees changes, there is no point in turning it off or clearing it.

I have /ialfill on my maybe list.

#2

Updated by westor (GR) 4 months ago

I agree that AdiIRC uses most clever method than /WHO #channel, and i can see that /names on Freenode doesn't including userhost as other IRCD's so i think you're right here.

But i think /ialclear [nick] and /ial [on|off] commands are good to be included in order you don't want any informations to be saved on memory (useful for old running machines) and if you want to clear a nickname or clear + update the IAL there is not a way now.

Anyway, thanks for response.

#3

Updated by Per Amundsen 4 months ago

  • Status changed from New to Invalid

The list doesn't use much memory, we are talking bytes, not even kilobytes, there is nothing to save, and instead you would lose all kinds of features.

There is no need to clear the list to update it, as I already mentioned, AdiIRC updates with new changes, it doesn't have to be cleared before new or changed hostnames are added/updated.

That means if you do /WHO, /WHOX, /WHOIS or any other command that returns a hostname, missing nicks/hostnames from the response is added or updated to the list.

On quit/part removes the nick from the list, so there is no wasted bytes.

#4

Updated by westor (GR) 4 months ago

Yeah ok, i can understand that AdiIRC is using IAL and in other features and i respect it, also i didn't knew that the size of memory saving is that low, ok then there is really no reason to be these there.

- thanks for response.

Also available in: Atom PDF