Project

General

Profile

Feature #4032

Add an delay on ServerList network connection due startup

Added by westor (GR) 6 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
07/14/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All

Description

Hello,

I wanan request an small addition related on ServerList feature, it would be nice to see a delay between each loop network connection that exists on the list because it will help when there are more than 1 networks saved.

Example: If someone has 5+ networks and every network has the option "Connect to this network on startup" and starts up the AdiIRC then AdiIRC will open 5 new connections directly (normally) but in old machines there is a lag-stuck-delay (5-10 secs) there, so it would be nice to having an option under 'Misc' tab on the ServerList to determind in how many seconds after the AdiIRC will open the new connection window (e.g: /server -n) to connect to that network.

So with that new feature the AdiiRC supposed to open all the network status windows on startup (if the 'Connect to this network on startup' option is checked) but it will connect to that network after X seconds delay that was set under Misc on ServerList, if the option "Connect to this network on startup" isn't checked then it will just do nothing because it supposed to work if that option is enabled.

Example Image:

- Thanks!

History

#1

Updated by Per Amundsen 6 months ago

I don't think this will accomplish what you think it will.

Instead try enable "Minimize server window" and set each channel join to minimize as well.

#2

Updated by westor (GR) 6 months ago

I already using both options :p

#3

Updated by Per Amundsen 6 months ago

Can you explain a little more the problem, e.g if all windows are minimized they wont take the focus from the Editbox, so what is the problem?

Have you tried connecting using a stock AdiIRC with no scripts?

Have you tried using a on CONNECT script with /server <network name in the network list> and /timer to connect ?

#4

Updated by westor (GR) 6 months ago

The problem is that it should be an delay between each new server window created on startup, because now i have 6 and each of one except the first one are minimizing on startup and connecting to the associate network/server. AdiIRC should has by default an delay there.

AdiiRC now is working like...

Starting up..
Opening 6 new server windows (directly) and connecting to their associated network/server.

It should be working like.

Starting up..
Opening 1st new server window (directly) and connecting to it associated network/server.
After X seconds Opening 2nd new server window and connecting to it associated network/server.
After X seconds Opening 3rd new server window and connecting to it associated network/server.
....

This could be script of course, but it would be nice to see there an option per network or global option to set an X delay to connect into the next server from Server List, that option that i request helping solving an stuck if you force adiirc to connect on startup on 6+ networks from Server List and joining into channels (especially for old machines).

- Thanks!

#5

Updated by Per Amundsen 6 months ago

You still haven't really explained the problem with opening server windows in a minimised state, it should be near instant and not a problem.

You also didn't answer the last 2 questions.

I'd rather figure out what the problem is instead of randomly adding options which so far only you seem to need.

#6

Updated by westor (GR) 6 months ago

I am not actually telling that AdiIRC having a problem, on newer machines it working instantly but on old machines there is a stuck when massive connecting on startup on 6+ networks/servers, and i am suggesting to add an simple "*Delay between connections*" (look the example photo above) same as you have for Channels on Server List under Misc to determine in how many seconds i want to connect into that network in order to not force AdiIRC on startup to connect on 6+ network/servers instantly.

Sorry for confusing..

#7

Updated by Per Amundsen 6 months ago

"but on old machines there is a stuck when massive connecting on startup on 6+ networks/servers"

Do you have a old machine with this "stuck" problem or not? It's getting confusing.

#8

Updated by westor (GR) 6 months ago

Yes i have that's why i suggest an option to add a delay there.

#9

Updated by Per Amundsen 6 months ago

Okay great, then we should figure out why you have a problem and fix it instead of making options to mask the problem.

You mentioned already you have minimized server windows enabled, then there are 2 other things to test.

Have you tried connecting using a stock AdiIRC with no scripts to see if you still have the "stuck" problem?

Have you tried using a on CONNECT script with /server <network name in the network list> and /timer to connect to see if you still have the "stuck" problem?

Based on these answers I can look into adding debug information etc.

A better description of what "stuck" means would also be nice.

#10

Updated by westor (GR) 6 months ago

I made a code via ON START and added /timer to connect into every network related to Server List and it seems ok, i didn't tested on clean AdiIRC to see if it is occuring but so far as i used mSL as alternative it is ok and no need anything else.

- Thanks for response!

#11

Updated by Per Amundsen 5 months ago

  • Status changed from New to Rejected

Also available in: Atom PDF