Project

General

Profile

Bug #4035

closed

/mode #channel b doesn't updating $ibl() list

Added by westor (GR) over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Irc
Target version:
Start date:
07/15/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I'm using a code to update the currently channel $ibl() list on join, but it seems that AdiIRC doesn't update it.

Also you can reproduce if you do //mode #channel b and then call $ibl(#channel,0) identifier.

Example Reproduce Code:

ON ME:*:JOIN:#test_chan: { .who $chan | mode $chan b }

//echo -a IS: $ibl(#test_chan,0)

- Thanks!

#1

Updated by westor (GR) over 3 years ago

Also, it would be nice if AdiIRC could (because mIRC doesn't) do something extra about it (i don't know if this will be lag AdiIRC or not) that when i join in channel to automatically fill the b,e,I,q lists, it can of course be scripted but if AdiIRC has faster and better method it could be good to be added (at least as option in General tab).

#2

Updated by Per Amundsen over 3 years ago

  • Category changed from Scripting to Irc
  • Status changed from New to Resolved

Also, it would be nice if AdiIRC could (because mIRC doesn't) do something extra about it (i don't know if this will be lag AdiIRC or not) that when i join in channel to automatically fill the b,e,I,q lists, it can of course be scripted but if AdiIRC has faster and better method it could be good to be added (at least as option in General tab).

The only method is to send /mode #channel b, it's not faster by adiirc doing it compared to a script, but this can generate a lot of traffic when joining many channels same as /who, and this can get you kicked of the server so AdiIRC will not do that.

#3

Updated by Per Amundsen over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF