Project

General

Profile

Bug #4060

closed

Text view adds a empty line which interferes with some identifiers

Added by westor (GR) over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
08/09/2018
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

There is a bug, when i try to filter the following data AdiIRC messing them out.

Code:

alias test_filter {
  var %win = @Test
  var %f = test.db
  window -j $+ $lines(%f) %win
  loadbuf %win $qt(%f)
  filter -ceutww 2 32 %win %win
}

Data:

test_one 10
test_two 20
test_three 30

- Thanks!

#1

Updated by Per Amundsen over 3 years ago

  • Status changed from New to Resolved

This is not really related to /filter, it's because the text view returns newline separated lines which becomes 4 lines instead of 3.

#2

Updated by Per Amundsen over 3 years ago

  • Status changed from Resolved to Closed
#3

Updated by Per Amundsen over 3 years ago

I did change the status to resolved by removing the extra empty line from the text view in all scripting cases.

#4

Updated by Per Amundsen over 3 years ago

  • Subject changed from /filter -w doesn't filtering correctly the results to Text view adds a empty line which interferes with some identifiers

Also available in: Atom PDF