Project

General

Profile

Actions

Bug #4458

closed

Using window ids for @name with /window gives invalid parameters

Added by Jonathan Kay over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
01/22/2019
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
Yes

Description

Starting with Jan 22/2019 beta release, manipulating windows via /window and an @windowid outputs "/window: invalid parameters".

Repro:

- Open AdiIRC
- Type /query test
- Verify test is the 2nd window with //echo -ag $window(@2).title
- Try /window -w0 @2
- Try /window -w3 @2
- Try /window -a @2
- Try /window -a @1
etc.

I assume this is caused from #4437

If this is by design (which I assume it's not, as $window still works), any alternatives would be appreciated :)

Actions #1

Updated by Per Amundsen over 3 years ago

  • Category set to Scripting
  • Status changed from New to Resolved
  • Assignee set to Per Amundsen

Yeah I just discovered the same thing, making a new beta in a little while, thanks.

Actions #2

Updated by Per Amundsen over 3 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF