Project

General

Profile

Bug #4623

Clicking image when window isn't in focus and single click enabled copies the image's link to the clipboard instead of opening the link

Added by Jonathan Kay 3 months ago. Updated 3 months ago.

Status:
Assigned
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
06/19/2019
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Repro:

  1. Open AdiIRC
  2. Open Options
  3. In the Inline Images section, turn on "Use inline images"
  4. In the Links section, turn on "Open links with single click", then click Save/Close
  5. Connect to a server or whatever you want to get any window with text input
  6. Generate an inline image, ex: /echo -ag https://adiirc.com/images/adiirc3.png
  7. Switch focus to another window (ie. click the windows taskbar, alt-tab to another window, etc.), but one where you can still see the inline image
  8. Click on the inline image without changing focus back to AdiIRC, nothing will appear to occur as it's copied the link to the image to the clipboard instead of opening it
  9. Press Ctrl-V to verify it's copied the link to the clipboard (or use Windows clipbrd.exe to monitor)
  10. Click the image again, it will now attempt to open the link per normal since the window is in focus

Notes:

  • If using non-maximized MDI windows, switching the focus to another AdiIRC MDI window and clicking the image without changing focus to the image's window first has the same issue
  • If double-clicking the image with single click enabled, it still will not open, it still copies to the clipboard
  • With the single click option disabled, clicking the image when the window isn't in focus will still copy the link to the clipboard on double or single click, but double-clicking does open the image link as expected

Expected:

  • When single click links are enabled, it should open image link on single click regardless of focus
  • Should not copy to the clipboard unless told to

History

#1

Updated by Per Amundsen 3 months ago

  • Status changed from New to Assigned
  • Target version changed from 3.5 to 3.6

I agree with your observation. I haven't been able to figure out a way to fix this yet, but I'll figure it out eventually.

Also available in: Atom PDF