Project

General

Profile

Bug #4772

closed

$chan().rawmode and $chan().mode returns wrong value

Added by westor (GR) about 2 years ago. Updated about 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
11/29/2019
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I am testing AdiIRC in the new UnrealIRCD 5 (currently in RC2 stage) and i noticed that adiirc returns wrong the data that receive from RAW 324 .

Debug:

<- 29/Nov/2019 12:10:55 - :IRC.Network.Net 324 testnick #test +ntrPCH 30:86400

Examples:

/mode #test
//echo -a IS: $chan(#test).rawmode -- $chan(#test).mode

Now returns: IS: +CHnPrt 30:86400 -- +CHnPrt
It should return: IS: +ntrPCH 30:86400 +ntrPCH

- Thanks!

#1

Updated by westor (GR) about 2 years ago

Same issue happens in other IRCD's too (like FreeNode)

<- 29/Nov/2019 12:19:26 - :niven.freenode.net 324 westor ##windows +CPcnptjf 3:45 ##windows-please-register

//echo -a IS: $chan(##windows).rawmode -- $chan(##windows).mode

Now returns: IS: +cCfjnPpt ##windows-please-register 3:45 -- +cCfjnPpt
It should return: IS: +CPcnptjf 3:45 ##windows-please-register -- +CPcnptjf
#2

Updated by Per Amundsen about 2 years ago

  • Status changed from New to Invalid

Modes are sorted alphabetically in AdiIRC, that is by design.

Also available in: Atom PDF