Project

General

Profile

Bug #4890

closed

bug with command /me (ctcp and spamfilter Unrealircd 5)

Added by armin armin almost 2 years ago. Updated almost 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Irc
Target version:
Start date:
01/22/2020
Due date:
% Done:

0%

Estimated time:
Operative System:
Windows 7
Regression:
No

Description

Hello

Follow the steps to reproduce this bug:

1) Add this: /spamfilter add -regex C block 0 Bloqué www

2) Write " /me www testtt " in a channel with the server notices activated so that they appear in /debug @debug or in the snotices

3) You will receive this message on the active window and this is not normal: [13:52:03]> CTCP reply ACTION www testtt from irc.site.com

#1

Updated by armin armin almost 2 years ago

"/me www testtt" it's another person who has to write this, not on yourself

#2

Updated by Per Amundsen almost 2 years ago

What is not normal about it? What does the RAW IRC message look like?

It looks like it's trying to send a ACTION through NOTICE, I get the same result from both mirc/adiirc by doing //parseline -itq :irc.server.com NOTICE $me : $+ $chr(1) $+ ACTION www testtt from irc.site.com $+ $chr(1)

e.g ACTION/me is not supported in NOTICE messages.

#3

Updated by armin armin almost 2 years ago

The raw:
<- @time=2020-01-22T13:29:19.198Z :irc.site.com NOTICE Fast :[Spamfilter] matches filter 'www': [PRIVMSG #chan: 'ACTION www testtt'] [URL bloquée]

On window active in red: [14:33:56] > CTCP reply ACTION www testtt from irc.site.com

#4

Updated by Per Amundsen almost 2 years ago

  • Category set to Irc
  • Status changed from New to Resolved
  • Assignee set to Per Amundsen

Okay, it should check for $chr(1) at the start of the message, fixed in next beta.

#5

Updated by Per Amundsen almost 2 years ago

  • Status changed from Resolved to Closed
#6

Updated by armin armin almost 2 years ago

ok thank you, I will test as soon as it is available

Also available in: Atom PDF