Project

General

Profile

Bug #4908

closed

AdiIRC should not parse chathistory in some of it's features

Added by westor (GR) almost 2 years ago. Updated almost 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Irc
Target version:
Start date:
01/30/2020
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I am using UnrealIRCD 5 that supports chathistory (https://www.unrealircd.org/docs/Channel_history) now the problem is that AdiIRC is parsing that chathistory in some features that it shouldn't parse it , i will provide some examples to make you understand what i mean.

Rawlog:

<- 30/Ιαν/2020 11:28:53 - @time=2020-01-30T09:28:53.773Z;msgid=HiVlyDhhttSCzQGl60ehc5-8z84irZmfahes2BZ++saBg;account=westor :westor!westor@I.Would.Like.To.Kiss.You.But.I.Cant.Tell.Me.Why.Not.My.BaBy JOIN #testing westor ::: 4Oti Arxizei Me XARA Telionei Me KARRA ::
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 353 westor @ #testing :westor!westor@I.Would.Like.To.Kiss.You.But.I.Cant.Tell.Me.Why.Not.My.BaBy 
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 366 westor #testing :End of /NAMES list.
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR BATCH +yrgfdZt6hhHraUX1Acn4Jc chathistory #testing
<- 30/Ιαν/2020 11:28:53 - @batch=yrgfdZt6hhHraUX1Acn4Jc;time=2020-01-30T09:04:01.596Z;msgid=sSd64oRSlz0pluad7rtanb;account=tester :tester!mSL-473@DE38F073.E9CE96C9.3C097FA3.IP PRIVMSG #testing :i testing now westor
<- 30/Ιαν/2020 11:28:53 - @batch=yrgfdZt6hhHraUX1Acn4Jc;time=2020-01-30T09:04:02.596Z;msgid=3a693CCMIE0MfNVM8Nqba7;account=tester :tester!mSL-473@DE38F073.E9CE96C9.3C097FA3.IP PRIVMSG #testing :i testing now westor
<- 30/Ιαν/2020 11:28:53 - @batch=yrgfdZt6hhHraUX1Acn4Jc;time=2020-01-30T09:04:03.096Z;msgid=tfPlm8OSoiY9d7h3gbDA2z;account=tester :tester!mSL-473@DE38F073.E9CE96C9.3C097FA3.IP PRIVMSG #testing :i testing now westor
<- 30/Ιαν/2020 11:28:53 - @batch=yrgfdZt6hhHraUX1Acn4Jc;time=2020-01-30T09:09:14.971Z;msgid=XySFpMNZB9tfQqyG7TAnR0 :mibbit_tester!4f677102@1439B751.33346819.32B6C63.IP PRIVMSG #testing :testing now westor
<- 30/Ιαν/2020 11:28:53 - @batch=yrgfdZt6hhHraUX1Acn4Jc;time=2020-01-30T09:09:16.048Z;msgid=C9Bevx3jBj5Z1B96GkMhnY :mibbit_tester!4f677102@1439B751.33346819.32B6C63.IP PRIVMSG #testing :testing now westor
<- 30/Ιαν/2020 11:28:53 - @batch=yrgfdZt6hhHraUX1Acn4Jc;time=2020-01-30T09:09:16.693Z;msgid=aTcTeySIH1hmb3dfto8xaD :mibbit_tester!4f677102@1439B751.33346819.32B6C63.IP PRIVMSG #testing :testing now westor
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR BATCH -yrgfdZt6hhHraUX1Acn4Jc
-> 30/Ιαν/2020 11:28:53 - MODE #testing
-> 30/Ιαν/2020 11:28:53 - WHOIS tester tester
-> 30/Ιαν/2020 11:28:53 - WHOIS tester tester
-> 30/Ιαν/2020 11:28:53 - WHOIS tester tester
-> 30/Ιαν/2020 11:28:53 - WHOIS sroelse sroelse
-> 30/Ιαν/2020 11:28:53 - WHOIS mibbit_tester mibbit_tester
-> 30/Ιαν/2020 11:28:53 - WHOIS mibbit_tester mibbit_tester
-> 30/Ιαν/2020 11:28:53 - WHOIS mibbit_tester mibbit_tester
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 324 westor #testing +sntPHf 30:10080m [6c#C5,6j#i5,8m#M5,6n#N5,6t#b]:10 
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 329 westor #testing 1580374300
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 402 westor tester :No such server
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 402 westor tester :No such server
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 402 westor tester :No such server
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 402 westor mibbit_tester :No such server
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 402 westor mibbit_tester :No such server
<- 30/Ιαν/2020 11:28:53 - :ReaL.ChatNet.GR 402 westor mibbit_tester :No such server

Issues:

1. According the above rawlog, i joined a channel that someone before called my name, so now because i have in my AdiIRC "Highlights -> Whois on: -> Highlights" option enabled, it sending a /whois that it shouldn't because it's chathistory and not a real event.

2. According the above rawlog, the ON *:TEXT:*:#testing: { echo -s IS: $1- } is working that it shouldn't working because it is not a real text event in the channel.

So far i only reproduced these 2 issues, i don't know if it could effect more AdiIRC features too.

- Thanks!

#1

Updated by Per Amundsen almost 2 years ago

  • Status changed from New to Invalid

Also available in: Atom PDF