Project

General

Profile

Bug #5043

closed

$keyval in on keydown returns incorrect value

Added by O uims over 1 year ago. Updated 4 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
04/10/2020
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

if you press H on your keyboard, the key value should be 72, not 104.

#1

Updated by O uims over 1 year ago

the $keyval value*

#2

Updated by Per Amundsen over 1 year ago

Maybe, I know mirc recently changed this, but it also breaks all current on KEYDOWN/KEYUP mirc scripts, it should probably be reverted.

#3

Updated by Oui Ouims 5 months ago

For once that mIRC does something great and doesn't keep broken behavior for the sake of backward compat, I'm not sure why you wouldn't want to comply.
Multiple mIRC versions has been released since, this change is going nowhere because the previous behavior severely limited the usage of the events.
Thing is, most previous script only ever used these events for key value which didn't not change.
Other scripts which used different key were already broken and people have complained as much. On keydown/up event have been broken in mirc and adiirc since the implementation of it, day 1.
Please fix this or newer scripts can't use such events correctly.

#4

Updated by Per Amundsen 4 months ago

  • Category set to Scripting
  • Status changed from New to Resolved
  • Assignee set to Per Amundsen
  • Target version changed from 3.9 to 4.0

I was waiting to see if it would be reverted because it breaks some scripts I know are in use, but it doesn't seem to be the case, so I have changed it for next beta.

#5

Updated by Per Amundsen 4 months ago

  • Status changed from Resolved to Closed
#6

Updated by Oui Ouims 4 months ago

Thanks for the fix.

Like I said, it can't break scripts more than they already were, these events were broken to start with, anyone claiming that their script is now broken with the fix would only be blind to the fact that their script were broken before, they just wouldn't see it.

Also available in: Atom PDF