Project

General

Profile

Bug #5068

closed

AdiIRC doesn't display or update nicklist on self nickname change

Added by westor (GR) 2 months ago. Updated about 2 months ago.

Status:
Invalid
Priority:
Normal
Assignee:
Category:
Irc
Target version:
Start date:
05/27/2020
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

Hello,

I am testing adiirc on unrealircd 5.0.5 with atheme 7.0.3-rc2 services i saw something strange that cannot explain it.

When i execute /ns regain <nickname> <password> , services gains the nickname back so changing the old nickname to the new_aaa and auto-identify also giving +r usermode, then when i try to change the regained nickname to an other i get -r usermode then the adiirc changes that nickname but doesn't display the nickname change information also doesn't either update the nicklist to new nickname.

NOTE : This is ONLY happening when i am joined into a channel.

Rawlog:

-> 27/Μαϊ/2020 23:45:23 - @label=0011 ns regain new_aaa test12345
<- 27/Μαϊ/2020 23:45:24 - @time=2020-05-27T20:45:25.407Z;msgid=RoLc2WphCr7OPSDjjPHIWU :old!Username@C7462A00.2B27B9BE.E62F24FD.IP NICK :new_aaa
<- 27/Μαϊ/2020 23:45:24 - @time=2020-05-27T20:45:25.407Z;msgid=RoLc2WphCr7OPSDjjPHIWU :old NICK :new_aaa
<- 27/Μαϊ/2020 23:45:24 - @time=2020-05-27T20:45:25.407Z;msgid=TMt9Im8lk3SluNYx2fFGBU :NickServ!bot@services.network.gr NOTICE new_aaa :new_aaa has been regained.
<- 27/Μαϊ/2020 23:45:24 - @time=2020-05-27T20:45:25.407Z;msgid=aX9qqXTNh5xvx58gjj2kyR :NickServ!bot@services.network.gr NOTICE new_aaa :Last login from: Username@77.49.6.29 on May 27 22:44:18 2020 +0200.
<- 27/Μαϊ/2020 23:45:24 - :NickServ MODE new_aaa :+r
-> 27/Μαϊ/2020 23:45:36 - PING :IRC.Network.GR
<- 27/Μαϊ/2020 23:45:36 - :IRC.Network.GR PONG IRC.Network.GR :IRC.Network.GR
-> 27/Μαϊ/2020 23:45:39 - NICK :new
<- 27/Μαϊ/2020 23:45:39 - @time=2020-05-27T20:45:40.755Z;msgid=5H257k8Ie6jM7zjRpDztzi :new_aaa NICK :new
<- 27/Μαϊ/2020 23:45:39 - :IRC.Network.GR MODE new :-r

Image example: https://i.imgur.com/s2susvF.png

#1

Updated by westor (GR) about 2 months ago

You can safe close that report, it was an IRCD fault, AdiIRC was working incorrect in this case because IRCD wasn't act correctly.

Sorry for this mess...

#2

Updated by Per Amundsen about 2 months ago

  • Status changed from New to Invalid

Good to know

Also available in: Atom PDF