Project

General

Profile

Actions

Bug #5355

closed

$regsubex() & \0

Added by psycho ™ almost 3 years ago. Updated over 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
06/30/2021
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
No

Description

in $regsubex \0 should report the total number of captures and not the total number of matches.

Running the code below in AdiIRC returns 10101010101010101010

$regsubex($str(x,10),/./g,\0) 

when it should return 0000000000

mIRC returns 0000000000

Actions #1

Updated by psycho ™ almost 3 years ago

And to compensate for mIRC being broken we need a way to get the total number of match
something like \@
since knowing the total number of captures is completely useless in 99,99999999% of all practical cases

Actions #2

Updated by Per Amundsen almost 3 years ago

  • Status changed from New to Resolved

Thanks, fixed this for next beta and added \@ which is subject to change if there are compatibility problems.

Actions #3

Updated by Per Amundsen almost 3 years ago

  • Status changed from Resolved to Closed
Actions #4

Updated by Per Amundsen over 2 years ago

  • Subject changed from $subregex & \0 to $regsubex() & \0
Actions

Also available in: Atom PDF