Project

General

Profile

Actions

Feature #5476

closed

Update version in Control Panel | 'Add or Remove Programs' when updating via built-in updater

Added by Kostas K about 2 years ago. Updated about 2 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Interface
Target version:
Start date:
01/23/2022
Due date:
% Done:

0%

Estimated time:
Operative System:
All

Description

Greetings

I have latest AdiIRC beta 4.2 on win 11.

First of all, I'm glad that AdiIRC is listed in 'winget upgrade' :

The (installed) version above, 3.9, is the one at the time of the initial install. (see: Control Panel | Add or Remove Programs (ARP) :

But, currently, the latest AdiIRC stable version is 4.1 and beta has become 4.2 .

I am aware the that current update procedure is to just download the AdiIRC executable in temp and copy it to 'Program Files'.
Nevertheless, I'd like to ask you please to consider, if possible, with every update using the built-in updater, the version in ARP to change accordingly (in my case to 4.2) .

Thank you

Actions #1

Updated by Kostas K about 2 years ago

  • Subject changed from Add version to the installer (for winget) to Update version in "Add or Remove Programs" when updating via built-in updater
Actions #2

Updated by Kostas K about 2 years ago

  • Subject changed from Update version in "Add or Remove Programs" when updating via built-in updater to Update version in Control Panel | 'Add or Remove Programs' when updating via built-in updater
Actions #3

Updated by Kostas K about 2 years ago

  • Tracker changed from Bug to Feature
  • Description updated (diff)
  • Regression deleted (No)
Actions #4

Updated by Kostas K about 2 years ago

  • Description updated (diff)
Actions #5

Updated by Per Amundsen about 2 years ago

What is the significance of this? I don't know anything about how winget works.

Actions #6

Updated by Per Amundsen about 2 years ago

Should also clarify that I did not add AdiIRC to winget.

Actions #7

Updated by Kostas K about 2 years ago

I thought you were aware about winget and that AdiIRC has been included in its community repo..

Anyway, I found that AdiIRC was added in the community repo 9 days ago via this pull request: New package: PerAmundsen.AdiIRC version 4.1 #40772 (I believe its author should inform you about it)

Windows Package Manager (winget) is a package manager by Microsoft. It's a command line tool.
The program is distributed with 'App Installer', which you can install either from the Microsoft Store page or from the project's GitHub repo .
With this tool the user can search for packages(programs) of interest, install/uninstall and check for and/or upgrade packages, all from CLI.
winget upgrade shows available package updates, winget upgrade -all the user can upgrade all programs with updates at once, or with winget upgrade PACKAGENAME to upgrade only the specified package.

Closing, for reference, in my case winget upgrade shows:

Actions #8

Updated by Per Amundsen about 2 years ago

Okay, being on winget is fine, I don't care about that.

But I want to understand what's the significance of the version number in "Add/Remove programs" and whether it being wrong causes problems with winget?

E.g is this just about how the version is displayed in "Add/Remove programs" or is there an actual problem?

Actions #9

Updated by Kostas K about 2 years ago

In Winget upgrade's output, the 'Version' column reflects the version number in "Add/Remove programs" (ARP), and the 'Available' column shows any new package versions that may exist according to the community repo data.
In my case AdiIRC is shown in winget as 3.9 (ARP version), which is that of my initial install via the installer. But, by using the built-in updater it has currently become 4.2 (beta). Alternatively, if I used the stable version instead, it would be 4.1.

Currently, winget "wrongly" shows to me that a new AdiIRC version is available (4.1) . What I want is, since my AdiIRC version is 4.2, winget not to show it as outdated. This can only be achieved by bumping the ARP version on each update (fo reference, see e.g. this or this comment in the winget repo to confirm that winget retrieves package versions from ARP).

Actions #10

Updated by Per Amundsen about 2 years ago

  • Category set to Interface
  • Status changed from New to Assigned
  • Assignee set to Per Amundsen

I see, I'll look into that.

Actions #11

Updated by Per Amundsen about 2 years ago

  • Status changed from Assigned to Resolved
Actions #12

Updated by Per Amundsen about 2 years ago

  • Status changed from Resolved to Closed
Actions #13

Updated by Kostas K about 2 years ago

Thanks for your quick response.
I just updated my beta installation to today's beta (2022/11/28) and unfortunately the version number in "Add/Remove programs" remained the same, 3.9
and winget upgrade still reports it as outdated:

Actions #14

Updated by Per Amundsen about 2 years ago

Yeah it wont work until the next update since all the code for doing it is in the new beta.

Actions #15

Updated by Kostas K about 2 years ago

Thanks a lot for clarifying.

Actions #16

Updated by Kostas K about 2 years ago

With todays beta I confirmed in action that it's fixed. Thanks a lot!

Actions #17

Updated by Per Amundsen about 2 years ago

Excellent.

Actions

Also available in: Atom PDF