Project

General

Profile

Actions

Bug #5514

closed

/sockudp -k doesn't work

Added by westor (GR) 6 months ago. Updated 6 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Scripting
Target version:
Start date:
03/27/2022
Due date:
% Done:

0%

Estimated time:
Operative System:
All
Regression:
Yes

Description

Hello,

I was testing the following command to connect using UDP on a server but AdiIRC returns an unexpected error.

Example:

//sockudp -k test 194.87.183.183 50008 $str($chr(255),4) $+ challenge rcon

Code:
ON *:UDPREAD:*: {
  var %test
  sockread -f %test

  echo -a IS: %test
}

Error: /sockudp: port error

NOTE : Don't try to compare with mIRC because it is also broken on 7.x but working on 6.x but there seems to be an other problem.

- Thanks!

Actions #1

Updated by Per Amundsen 6 months ago

  • Subject changed from /sockudp -k not working to /sockudp -k doesn't work
  • Status changed from New to Resolved
  • Regression changed from No to Yes

There is a regression bug with /sockudp after adding -u, but I don't think it's related to this, the server doesn't seem to send a response.

I fixed the regression, any other issue has to be on the other end.

Actions #2

Updated by Per Amundsen 6 months ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF